Knowledge Center Search


 

2013-10 Security Bulletin: Junos: SRX flowd core due to buffer overflow while processing telnet protocol (CVE-2013-6013)

  [JSA10594] Show KB Properties

  [JSA10594] Hide KB Properties

Categories:
Security Advisories ID: JSA10594
Last Updated: 09 Oct 2013
Version: 1.0

Product Affected:
SRX Series services gateways running Junos OS 10.4, 11.4, or 12.1X44

Problem:
 Due to a buffer overflow vulnerability in the SRX Series flow daemon (flowd) while processing certain crafted telnet protocol messages, a remote attacker may be able to execute arbitrary code leading to a complete compromise of the system. This issue only occurs if telnet pass-through authentication is configured on the firewall. A sample affected configuration is shown below:
user@junos# show access
profile FWAUTH {
    authentication-order password;
    client FWClient1 {
        firewall-user {
            password "$9$XHhxVYGDkf5F"; ## SECRET-DATA
        }
    }
}
firewall-authentication {
    pass-through {
        default-profile FWAUTH;
        telnet {
            banner {
                success "WELCOME TO JUNIPER TELNET SESSION";
            }
        }
    }
}
 
user@junos# show security policies
...
from-zone UT-ZONE to-zone T-ZONE {
    policy P1 {
       match {
            source-address any;
            destination-address any;
            application junos-telnet;
       }
       then {
            permit {
                firewall-authentication {
                    pass-through {
                        client-match FWClient1;
                    }
                }
            }
       }
    }
}
Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

No other Juniper Networks products or platforms are affected by this issue.

This issue has been assigned CVE-2013-6013.

Solution:
The following software releases have been updated to resolve this specific issue:
  • All Junos OS software releases built on or after 2013-07-11, or
  • Junos OS 10.4S14, 11.4R7-S2, 11.4R8, 12.1X44-D15, 12.1X45-D10, and all subsequent releases (i.e. all releases built after 12.1X45-D10).
Customers can confirm the build date of any Junos OS release by issuing the command 'show version detail'.

This issue is being tracked as PR 861558 and is visible on the Customer Support website.

KB16765 - "In which releases are vulnerabilities fixed?" describes which release vulnerabilities are fixed as per our End of Engineering and End of Life support policies.

Workaround:
If telnet pass-through authentication is not required, disabling the feature will completely mitigate this vulnerability.

Implementation:
How to obtain fixed software:

Security vulnerabilities in Junos are fixed in the next available Maintenance Release of each supported Junos version. In some cases, a Maintenance Release is not planned to be available in an appropriate time-frame. For these cases, Service Releases are made available in order to be more timely. Security Advisory and Security Notices will indicate which Maintenance and Service Releases contain fixes for the issues described. Upon request to JTAC, customers will be provided download instructions for a Service Release. Although Juniper does not provide formal Release Note documentation for a Service Release, a list of "PRs fixed" can be provided on request.

Related Links:

CVSS Score:
10.0 (AV:N/AC:L/Au:N/C:C/I:C/A:C)

Risk Level:
Critical

Risk Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."

Acknowledgements:
 

 

 

ASK THE KB

Question or KB ID:


 


 

 
Copyright© 1999-2012 Juniper Networks, Inc. All rights reserved.