Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

RPD cores when injected with malformed PIM messages

0

0

Article ID: JSA10423 SECURITY_ADVISORIES Last Updated: 09 May 2013Version: 4.0
Legacy Advisory Id:
PSN-2010-01-627
Product Affected:
All JUNOS Devices
Problem:
Specifically crafted and malformed PIM messages injected into the router with PIM running will crash the RPD process.

This issue was discovered through internal and customer security testing.

Solution:
Customers are recommended to upgrade JUNOS through planned and methodical upgrade processes.

All JUNOS software releases built on or after January 24, 2009 has fixed this issue with malformed PIM messages. This specifically includes 8.1-20090821-SR, 8.5-20090226-SR, 9.1-20090321-SR, 9.2-20090320-SR, 9.2R4, 9.3-20090213-SR, 9.3R3, 9.4R2, and all subsequent releases.

PR Reference for this issue is PR 417088 & 412978

Implementation:
How to obtain Service Releases:

Security vulnerabilities are fixed in the next available Maintenance Release of each supported JUNOS version. In some cases, a Maintenance Release is not planned to be available in an appropriate time-frame. For these cases, Service Releases are made available in order to be more timely. Security Advisory notices will indicate which Maintenance and/or Service Releases contain fixes for the issues described. Upon request to JTAC, customers will be provided download instructions for a Service Release. Although Juniper does not provide formal Release Note documentation for a Service Release, a list of "PRs fixed" can be provided on request.
CVSS Score:
7.1 (AV:N/AC:M/Au:N/C:N/I:N/A:C)
Severity Level:
Critical
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search