Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2018-10 Security Bulletin: Junos OS: Denial of Service vulnerability in MS-PIC, MS-MIC, MS-MPC, MS-DPC and SRX flow daemon (flowd) related to SIP ALG (CVE-2018-0051)

0

0

Article ID: JSA10885 SECURITY_ADVISORIES Last Updated: 10 Oct 2018Version: 2.0
Product Affected:
This issue affects Junos OS 12.1X46, 12.3X48, 15.1, 15.1F6, 15.1X49, 16.1, 16.2, 17.1, 17.2, 17.3, 17.4.
Problem:
A Denial of Service vulnerability in the SIP application layer gateway (ALG) component of Junos OS based platforms allows an attacker to crash MS-PIC, MS-MIC, MS-MPC, MS-DPC or SRX flow daemon (flowd) process.

This issue affects Junos OS devices with NAT or stateful firewall configuration in combination with the SIP ALG enabled.

SIP ALG is enabled by default on SRX Series devices except for SRX-HE devices. SRX-HE devices have SIP ALG disabled by default.

The status of ALGs in SRX device can be obtained by executing the command:
show security alg status

Affected releases are Juniper Networks Junos OS:
  • 12.1X46 versions prior to 12.1X46-D77;
  • 12.3X48 versions prior to 12.3X48-D70;
  • 15.1X49 versions prior to 15.1X49-D140;
  • 15.1 versions prior to 15.1R4-S9, 15.1R7-S1;
  • 15.1F6;
  • 16.1 versions prior to 16.1R4-S9, 16.1R6-S1, 16.1R7;
  • 16.2 versions prior to 16.2R2-S7, 16.2R3;
  • 17.1 versions prior to 17.1R2-S7, 17.1R3;
  • 17.2 versions prior to 17.2R1-S6, 17.2R2-S4, 17.2R3;
  • 17.3 versions prior to 17.3R1-S5, 17.3R2-S2, 17.3R3;
  • 17.4 versions prior to 17.4R2.

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was seen during production usage.

No other Juniper Networks products or platforms are affected by this issue.

This issue has been assigned CVE-2018-0051.
 
Solution:

The following software releases have been updated to resolve these specific issues: 12.1X46-D77, 12.3X48-D70, 12.3X48-D75, 14.1X53-D47, 15.1R4-S9, 15.1R7-S1, 15.1X49-D140, 15.1X53-D471, 15.1X53-D490, 15.1X53-D59, 15.1X53-D67, 16.1R4-S9, 16.1R6-S1, 16.1R7, 16.2R2-S7, 16.2R3, 17.1R2-S7, 17.1R3, 17.2R1-S6, 17.2R2-S4, 17.2R3, 17.3R1-S5, 17.3R2-S2, 17.3R3, 17.4R2, 18.1R1, 18.1X75-D10, 18.2R1, 18.2X75-D5, and all subsequent releases.

This fix has also been proactively committed into other releases that might not support SIP ALG configuration.

This issue is being tracked as PR 1326394 which is visible on the Customer Support website.

Note: Juniper SIRT's policy is not to evaluate releases which are beyond End of Engineering (EOE) or End of Life (EOL).
 

Workaround:

Disable the use of the SIP ALG feature if it is not needed.
 

Implementation:
Software Releases, patches and updates are available at https://www.juniper.net/support/downloads/.
 
Modification History:
‚Äč2018-10-10: Initial publication

CVSS Score:
7.5 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
Severity Level:
High

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search