Support Support Downloads Knowledge Base Service Request Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2018-10 Security Bulletin: Junos OS: Denial of service in telnetd (CVE-2018-0061)

0

0

Article ID: JSA10896 SECURITY_ADVISORIES Last Updated: 10 Oct 2018Version: 1.0
Product Affected:
This issue affects Junos OS 12.1X46, 12.3, 12.3X48, 15.1, 15.1X49, 15.1X53, 16.1, 16.2, 17.1, 17.2, 17.2X75, 17.3, 17.4, 18.2X75.
Problem:

A denial of service vulnerability in the telnetd service on Junos OS allows remote unauthenticated users to cause high CPU usage which may affect system performance.

Affected releases are Juniper Networks Junos OS:

  • 12.1X46 versions prior to 12.1X46-D81 on SRX Series;
  • 12.3 versions prior to 12.3R12-S11;
  • 12.3X48 versions prior to 12.3X48-D80 on SRX Series;
  • 15.1 versions prior to 15.1R7;
  • 15.1X49 versions prior to 15.1X49-D150, 15.1X49-D160 on SRX Series;
  • 15.1X53 versions prior to 15.1X53-D59 on EX2300/EX3400 Series;
  • 15.1X53 versions prior to 15.1X53-D68 on QFX10K Series;
  • 15.1X53 versions prior to 15.1X53-D235 on QFX5200/QFX5110 Series;
  • 15.1X53 versions prior to 15.1X53-D495 on NFX Series;
  • 16.1 versions prior to 16.1R4-S12, 16.1R6-S6, 16.1R7;
  • 16.2 versions prior to 16.2R2-S7, 16.2R3;
  • 17.1 versions prior to 17.1R2-S9, 17.1R3;
  • 17.2 versions prior to 17.2R2-S6, 17.2R3;
  • 17.2X75 versions prior to 17.2X75-D100;
  • 17.3 versions prior to 17.3R2-S4, 17.3R3;
  • 17.4 versions prior to 17.4R1-S5, 17.4R2;
  • 18.2X75 versions prior to 18.2X75-D5.

This issue affects devices with telnet service enabled.

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was found during internal product security testing or research.

This issue has been assigned CVE-2018-0061.
 

Solution:

The following software releases have been updated to resolve this specific issue: 12.1X46-D81, 12.3R12-S11, 12.3R13, 12.3X48-D80, 15.1R7, 15.1X49-D150, 15.1X49-D160, 15.1X53-D235, 15.1X53-D495, 15.1X53-D59, 15.1X53-D68, 16.1R4-S12, 16.1R6-S6, 16.1R7, 16.2R2-S7, 16.2R3, 17.1R2-S9, 17.1R3, 17.2R2-S6, 17.2R3, 17.2X75-D100, 17.2X75-D110, 17.3R2-S4, 17.3R3, 17.4R1-S5, 17.4R2, 18.1R1, 18.1R2, 18.2R1, 18.2X75-D5, and all subsequent releases.

This issue is being tracked as PR 1331234 which is visible on the Customer Support website.

Note: Juniper SIRT's policy is not to evaluate releases which are beyond End of Engineering (EOE) or End of Life (EOL).
 

Workaround:

Disabling the telnet service will completely mitigate this issue.
 

Implementation:
Software Releases, patches and updates are available at https://www.juniper.net/support/downloads/.
 
Modification History:
‚Äč2018-10-10: Initial publication

CVSS Score:
5.3 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L)
Severity Level:
Medium
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."

Related Links

Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Security Alerts and Vulnerabilities

Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search