Knowledge Search


×
 

2019-01 Security Bulletin: Junos OS: RPD crash upon receipt of malformed PIM packet (CVE-2019-0013)

  [JSA10913] Show Article Properties


Product Affected:
This issue affects Junos OS 12.1X46, 12.3X48, 15.1, 15.1X49, 15.1X53, 16.1, 16.2, 17.1, 17.2, 17.3, 17.4.
Problem:

The routing protocol daemon (RPD) process will crash and restart when a specific invalid IPv4 PIM Join packet is received. While RPD restarts after a crash, repeated crashes can result in an extended Denial of Service (DoS) condition.

This issue only affects devices with IPv4 PIM enabled.  Devices with PIM disabled, or with IPv6 PIM only enabled are unaffected by this vulnerability.

Affected releases are Juniper Networks Junos OS:

  • 12.1X46 versions prior to 12.1X46-D77;
  • 12.3X48 versions prior to 12.3X48-D77;
  • 15.1 versions prior to 15.1F6-S10, 15.1R6-S6, 15.1R7;
  • 15.1X49 versions prior to 15.1X49-D150;
  • 15.1X53 versions prior to 15.1X53-D233, 15.1X53-D59;
  • 16.1 versions prior to 16.1R3-S8, 16.1R4-S8, 16.1R7;
  • 16.2 versions prior to 16.2R2-S6;
  • 17.1 versions prior to 17.1R2-S6, 17.1R3;
  • 17.2 versions prior to 17.2R2-S3, 17.2R3;
  • 17.3 versions prior to 17.3R2-S4, 17.3R3;
  • 17.4 versions prior to 17.4R2.

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was seen during production usage.

This issue has been assigned CVE-2019-0013.
 

Solution:

The following software releases have been updated to resolve this specific issue: Junos OS 12.1X46-D77, 12.3X48-D77, 15.1F6-S10, 15.1R6-S6, 15.1R7, 15.1X49-D150, 15.1X53-D233, 15.1X53-D59, 16.1R3-S8, 16.1R4-S8, 16.1R7, 16.2R2-S6, 17.1R2-S6, 17.1R3, 17.2R2-S3, 17.2R3, 17.3R2-S4, 17.3R3, 17.4R2, 18.1R1, and all subsequent releases.
This issue is being tracked as PR 1293306 which is visible on the Customer Support website.
Note: Juniper SIRT's policy is not to evaluate releases which are beyond End of Engineering (EOE) or End of Life (EOL).

 

Workaround:
No known workaround exists for this issue.

However, the risk of hitting this issue can be reduced by disabling PIM Join make-before-break via the configuration command:
  set protocol pim join-make-before-break disable
Implementation:
Software Releases, patches and updates are available at https://www.juniper.net/support/downloads/.
 
Modification History:
2019-01-09: Initial publication
2019-01-10: Minor edit on the Solution section
2019-01-14: Added risk mitigation config option to WORKAROUND section, and clarified that PIM must be enabled to be vulnerable
2019-01-22: Minor update on the Solution section


Related Links:
CVSS Score:
6.5 (CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
Severity Level:
Medium
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."