Knowledge Search


×
 

2019-10 Security Bulletin: Junos OS: SRX Series: flowd process crash due to processing of specific transit IP packets (CVE-2019-0060)

  [JSA10959] Show Article Properties


Product Affected:
This issue affects Junos OS 15.1X49, 18.2, 18.4. Affected platforms: SRX Series.
Problem:

The flowd process, responsible for forwarding traffic in SRX Series services gateways, may crash and restart when processing specific transit IP packets through an IPSec tunnel. Continued processing of these packets may result in an extended Denial of Service (DoS) condition.

This issue only occurs when IPSec tunnels are configured. Systems without IPSec tunnel configurations are not vulnerable to this issue.

This issue affects Juniper Networks Junos OS:

  • 15.1X49 versions prior to 15.1X49-D171, 15.1X49-D180 on SRX Series;
  • 18.2 versions 18.2R2-S1 and later, prior to 18.2R3 on SRX Series;
  • 18.4 versions prior to 18.4R2 on SRX Series.


The following example shows a sample IPSec tunnel configuration:

[edit security ipsec]
security-association manual-sa1 {
...
}
[edit interfaces es-0/1/0]
...
family inet {
ipsec-sa manual-sa1;


Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was seen during production usage.

This issue has been assigned CVE-2019-0060.

Solution:

The following software releases have been updated to resolve this specific issue: 15.1X49-D171, 15.1X49-D180, 18.2R3, 18.4R2, 19.1R1, and all subsequent releases.

This issue is being tracked as PR 1409277 which is visible on the Customer Support website.

Note: Juniper SIRT's policy is not to evaluate releases which are beyond End of Engineering (EOE) or End of Life (EOL).
 

Workaround:
There are no viable workarounds for this issue.
 
Implementation:
Software Releases, patches and updates are available at https://www.juniper.net/support/downloads/.
 
Modification History:
2019-10-09: Initial Publication.
 
Related Links:
CVSS Score:
7.5 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
Severity Level:
High
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."