Support Support Downloads Knowledge Base Service Request Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2020-01 Security Bulletin: Junos OS: Path traversal vulnerability in J-Web (CVE-2020-1606)

0

0

Article ID: JSA10985 SECURITY_ADVISORIES Last Updated: 16 Jan 2020Version: 5.0
Product Affected:
This issue affects Junos OS 12.3, 12.3X48, 14.1X53, 15.1, 15.1F6, 15.1X49, 15.1X53, 16.1, 16.2, 17.1, 17.2, 17.3, 17.4, 18.1, 18.2, 18.3, 18.4, 19.1.
Problem:

A path traversal vulnerability in the Juniper Networks Junos OS device may allow an authenticated J-web user to read files with 'world' readable permission and delete files with 'world' writeable permission.

This issue does not affect system files that can be accessed only by root user.

This issue affects Juniper Networks Junos OS:

12.3 versions prior to 12.3R12-S13;

12.3X48 versions prior to 12.3X48-D85 on SRX Series;

14.1X53 versions prior to 14.1X53-D51;

15.1F6 versions prior to 15.1F6-S13;

15.1 versions prior to 15.1R7-S5;

15.1X49 versions prior to 15.1X49-D180 on SRX Series;

15.1X53 versions prior to 15.1X53-D238 on QFX5200/QFX5110 Series;

16.1 versions prior to 16.1R4-S13, 16.1R7-S5;

16.2 versions prior to 16.2R2-S10;

17.1 versions prior to 17.1R3-S1;

17.2 versions prior to 17.2R1-S9, 17.2R3-S2;

17.3 versions prior to 17.3R2-S5, 17.3R3-S5;

17.4 versions prior to 17.4R2-S9, 17.4R3;

18.1 versions prior to 18.1R3-S8;

18.2 versions prior to 18.2R3;

18.3 versions prior to 18.3R2-S3, 18.3R3;

18.4 versions prior to 18.4R2;

19.1 versions prior to 19.1R1-S4, 19.1R2.

This issue requires J-Web to be enabled on the device.

The examples of the config stanza affected by this issue:

[system services web-management http]
[system services web-management https]

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was discovered during an external security research.

This issue has been assigned CVE-2020-1606.

Solution:

The following software releases have been updated to resolve this specific issue: 12.3R12-S13, 12.3X48-D85, 14.1X53-D51, 15.1F6-S13, 15.1R7-S5, 15.1X49-D180, 15.1X53-D238, 16.1R4-S13, 16.1R7-S5, 16.2R2-S10, 17.1R3-S1, 17.2R1-S9, 17.2R3-S2, 17.3R2-S5, 17.3R3-S5, 17.4R2-S9, 17.4R3, 18.1R3-S8, 18.2R3, 18.3R2-S3, 18.3R3, 18.4R2, 19.1R1-S4, 19.1R2, 19.2R1, and all subsequent releases.

This issue is being tracked as 1431298.

Workaround:

Limit access to the J-Web interface to only trusted users to reduce risks of exploitation of this vulnerability.

Implementation:
Software Releases, patches and updates are available at https://www.juniper.net/support/downloads/.
Modification History:
2020-01-08: Initial Publication.
2020-01-16: Adding reference to https://jvn.jp/en/jp/JVN07375820/
CVSS Score:
5.4 (CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N)
Severity Level:
Medium
Acknowledgements:
The Juniper SIRT would like to would like to acknowledge and thank Toshitsugu Yoneyama of Mitsui Bussan Secure Directions, Inc. for finding and reporting this issue.

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Security Alerts and Vulnerabilities

Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search