Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2020-04 Security Bulletin: Junos OS: Multiple IPsec AH vulnerabilities resolved.

0

0

Article ID: JSA11016 SECURITY_ADVISORIES Last Updated: 08 Apr 2020Version: 5.0
Product Affected:
These issues affect Junos OS 15.1, 15.1X49, 15.1X53, 16.1, 16.2, 17.1, 17.2, 17.2X75, 17.3, 17.4, 18.1, 18.2, 18.2X75, 18.3, 18.4, 19.1, 19.2, 19.3.
Problem:

Multiple vulnerabilities that affect FreeBSD's implementation of IPSec's Authentication Header (AH) protocol have been fixed in Juniper Networks Junos OS.

These issues only affect systems configured for IPsec when the AH protocol is used.

These issues allow an attacker from a trusted host to potentially be able to take control of the device by sending a specifically constructed IP packet that may lead to a system crash. Additionally, an attacker from any host may crash the target by sending an arbitrary packet to the device causing a Denial of Service (DoS). Sustained receipt of these specifically constructed or arbitrary packets will result in an extended Denial of Service condition.

Devices not configured for IPsec AH use are not exploitable to these issues.

These issues affect:

Juniper Networks Junos OS

15.1 versions prior to 15.1R7-S6;

15.1X49 versions prior to 15.1X49-D200 on SRX Series;

15.1X53 versions prior to 15.1X53-D593 on EX2300, EX3400;

16.1 versions prior to 16.1R7-S7;

16.2 versions prior to 16.2R2-S11;

17.1 versions prior to 17.1R2-S11, 17.1R3-S2;

17.2 versions prior to 17.2R3-S3;

17.2X75 versions prior to 17.2X75-D44, 17.2X75-D105, 17.2X75-D110;

17.3 versions prior to 17.3R2-S5, 17.3R3-S7;

17.4 versions prior to 17.4R2-S9, 17.4R3;

18.1 versions prior to 18.1R3-S9;

18.2 versions prior to 18.2R2-S6, 18.2R3-S3;

18.2X75 versions prior to 18.2X75-D33, 18.2X75-D60, 18.2X75-D411, 18.2X75-D420;

18.3 versions prior to 18.3R1-S7, 18.3R2-S3, 18.3R3-S1;

18.4 versions prior to 18.4R1-S5, 18.4R2-S3, 18.4R3;

19.1 versions prior to 19.1R1-S4, 19.1R2, 19.1R3;

19.2 versions prior to 19.2R1-S2, 19.2R2;

19.3 versions prior to 19.3R1-S1, 19.3R2, 19.3R3.

These issues do not affect Junos OS prior to 15.1R1.

These issues exist where the ah protocol is configured or in use.

One example of one minimal configuration is the "manual" IPSec SA configuration:

security ipsec security-association <sa-name> manual direction <direction> protocol ah

Other configurations apply.

Juniper SIRT is not aware of any malicious exploitation of these vulnerabilities.

These issues were discovered during an external security research.

 
CVE CVSS Summary
CVE-2018-6918 7.5 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H) In FreeBSD before 11.1-STABLE, 11.1-RELEASE-p9, 10.4-STABLE, 10.4-RELEASE-p8 and 10.3-RELEASE-p28, the length field of the ipsec option header does not count the size of the option header itself, causing an infinite loop when the length is zero. This issue can allow a remote attacker who is able to send an arbitrary packet to cause the machine to crash.
CVE-2018-6916 9.8 (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H) In FreeBSD before 11.1-STABLE, 11.1-RELEASE-p7, 10.4-STABLE, 10.4-RELEASE-p7, and 10.3-RELEASE-p28, the kernel does not properly validate IPsec packets coming from a trusted host. Additionally, a use-after-free vulnerability exists in the IPsec AH handling code. This issue could cause a system crash or other unpredictable results.

 

Solution:

The following software releases have been updated to resolve these specific issues: 15.1R7-S6, 15.1X49-D200, 15.1X53-D593, 16.1R7-S7, 16.2R2-S11, 17.1R2-S11, 17.1R3-S2, 17.2R3-S3, 17.2X75-D44, 17.2X75-D105, 17.2X75-D110, 17.3R2-S5, 17.3R3-S7, 17.4R2-S9, 17.4R3, 18.1R3-S9, 18.2R2-S6, 18.2R3-S3, 18.2X75-D33, 18.2X75-D60, 18.2X75-D411, 18.2X75-D420, 18.3R1-S7, 18.3R2-S3, 18.3R3-S1, 18.4R1-S5, 18.4R2-S3, 18.4R3, 19.1R1-S4, 19.1R2, 19.1R3, 19.2R1-S2, 19.2R2, 19.3R1-S1, 19.3R2, 19.3R3, 19.4R1, and all subsequent releases.

These issues are being tracked as 1470693.

Workaround:

There are no known workarounds for AH-only configurations.

Customers may configure ESP instead of AH as it may be configured for both confidentiality and integrity.

Note: You can configure encryption when AH is not in use.

Implementation:
Software Releases, patches and updates are available at https://www.juniper.net/support/downloads/.
Modification History:
‚Äč2020-04-08: Initial publication
CVSS Score:
9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
Severity Level:
Critical
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search