Support Support Downloads Knowledge Base Apex Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2021-01 Security Bulletin: Junos OS: Upon receipt of certain protocol packets with invalid payloads a self-propagating Denial of Service may occur. (CVE-2021-0222)

0

0

Article ID: JSA11094 SECURITY_ADVISORIES Last Updated: 18 Jan 2021Version: 3.0
Product Affected:
This issue affects Junos OS 14.1X53, 15.1, 16.1, 17.1, 17.2, 17.3, 17.4, 18.1, 18.2, 18.3, 18.4, 19.1, 19.2, 19.3. Affected platforms: EX2300, EX3400, EX4300, EX4600, EX4650, QFX3500, QFX5100, QFX5110, QFX5120, QFX5200, QFX5210.
Problem:

A vulnerability in Juniper Networks Junos OS allows an attacker to cause a Denial of Service (DoS) to the device by sending certain crafted protocol packets from an adjacent device with invalid payloads to the device.

These crafted packets, which should be discarded, are instead replicated and sent to the RE. Over time, a Denial of Service (DoS) occurs. Continued receipt of these crafted protocol packets will cause an extended Denial of Service (DoS) condition, which may cause wider traffic impact due to protocol flapping.

An indication of compromise is to check "monitor interface traffic" on the ingress and egress port packet counts. For each ingress packet, two duplicate packets are seen on egress.

This issue can be triggered by IPv4 and IPv6 packets.

This issue affects all traffic through the device.

This issue affects:

Juniper Networks Junos OS:

  • 14.1X53 versions prior to 14.1X53-D53 on EX4300, QFX3500, QFX5100, EX4600;
  • 15.1 versions prior to 15.1R7-S6 on EX4300, QFX3500, QFX5100, EX4600;
  • 16.1 versions prior to 16.1R7-S7 on EX4300, QFX5100, EX4600;
  • 17.1 versions prior to 17.1R2-S11 on EX4300, QFX5100, EX4600;
  • 17.1 versions prior to 17.1R3-S2 on EX4300;
  • 17.2 versions prior to 17.2R1-S9 on EX4300;
  • 17.2 versions prior to 17.2R3-S3 on EX4300, QFX5100, EX4600, QFX5110, QFX5200;
  • 17.3 versions prior to 17.3R2-S5, 17.3R3-S7 on EX4300, QFX5100, EX4600, QFX5110, QFX5200;
  • 17.4 versions prior to 17.4R2-S9, 17.4R3 on EX4300, QFX5100, EX4600, QFX5110, QFX5200;
  • 18.1 versions prior to 18.1R3-S9 on EX4300, QFX5100, EX4600, QFX5110, QFX5200, QFX5210, EX2300, EX3400;
  • 18.2 versions prior to 18.2R2-S7 on EX4300;
  • 18.2 versions prior to 18.2R3-S3 on EX4300, QFX5100, EX4600, QFX5110, QFX5200, QFX5210, EX2300, EX3400;
  • 18.3 versions prior to 18.3R2-S3, on EX4300;
  • 18.3 versions prior to 18.3R1-S7, 18.3R3-S1 on EX4300, QFX5100, EX4600, QFX5110, QFX5200, QFX5210, QFX5120, EX4650, EX2300, EX3400;
  • 18.4 versions prior to 18.4R1-S5, 18.4R2-S3, 18.4R3 on EX4300, QFX5100, EX4600, QFX5110, QFX5200, QFX5210, QFX5120, EX4650, EX2300, EX3400;
  • 19.1 versions prior to 19.1R1-S4, 19.1R2-S1, 19.1R3 on EX4300, QFX5100, EX4600, QFX5110, QFX5200, QFX5210, QFX5120, EX4650, EX2300, EX3400;
  • 19.2 versions prior to 19.2R1-S4, 19.2R2 on EX4300;
  • 19.2 versions prior to 19.2R1-S3, 19.2R2 on QFX5100, EX4600, QFX5110, QFX5200, QFX5210, QFX5120, EX4650, EX2300, EX3400;
  • 19.3 versions prior to 19.3R2-S1, 19.3R3 on EX4300;
  • 19.3 versions prior to 19.3R1-S1, 19.3R2, 19.3R3 on QFX5100, EX4600, QFX5110, QFX5200, QFX5210, QFX5120, EX4650, EX2300, EX3400;

This issue was seen during production usage.

This issue has been assigned CVE-2021-0222.

Solution:

The following software releases have been updated to resolve this specific issue: 14.1X53-D53, 15.1R7-S6, 16.1R7-S7, 17.1R2-S11, 17.2R3-S3, 17.3R2-S5, 17.3R3-S7, 17.4R2-S9, 17.4R3, 18.1R3-S9, 18.2R3-S3, 18.4R1-S5, 18.4R2-S3, 18.4R3, 19.1R1-S4, 19.1R2-S1, 19.1R3, 19.2R2, 19.3R2-S1, 19.3R3, 19.4R1, and all subsequent releases.

This issue is being tracked as 1472704 and 1471922.

Workaround:
There are no available workarounds for this issue.
Implementation:
Software releases or updates are available for download at https://www.juniper.net/support/downloads/.
Modification History:
2021-01-13: Initial Publication.
2021-01-18: Additional letter 1 from 117 to 17 removed from version list.
CVSS Score:
7.4 (CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H)
Severity Level:
High
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search