Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2021-01 Security Bulletin: Junos OS: Privilege escalation in J-Web due to arbitrary command and code execution via information disclosure from another users active session (CVE-2021-0210)

0

0

Article ID: JSA11100 SECURITY_ADVISORIES Last Updated: 13 Jan 2021Version: 2.0
Product Affected:
This issue affects Junos OS 12.3, 17.3, 17.4, 18.1, 18.2, 18.3, 18.4, 19.1, 19.2, 19.3, 19.4, 20.1, 20.2.
Problem:

An Information Exposure vulnerability in J-Web of Juniper Networks Junos OS allows an unauthenticated attacker to elevate their privileges over the target system through opportunistic use of an authenticated users session.

This issue affects:

Juniper Networks Junos OS

  • 12.3 versions prior to 12.3R12-S17;
  • 17.3 versions prior to 17.3R3-S10;
  • 17.4 versions prior to 17.4R2-S12, 17.4R3-S3;
  • 18.1 versions prior to 18.1R3-S11;
  • 18.2 versions prior to 18.2R3-S6;
  • 18.3 versions prior to 18.3R2-S4, 18.3R3-S4;
  • 18.4 versions prior to 18.4R2-S5, 18.4R3-S5;
  • 19.1 versions prior to 19.1R1-S6, 19.1R2-S2, 19.1R3-S3;
  • 19.2 versions prior to 19.2R1-S5, 19.2R3, 19.2R3-S1;
  • 19.3 versions prior to 19.3R2-S4, 19.3R3;
  • 19.4 versions prior to 19.4R1-S3, 19.4R2-S2, 19.4R3;
  • 20.1 versions prior to 20.1R1-S4, 20.1R2;
  • 20.2 versions prior to 20.2R1-S1, 20.2R2.

The following minimal configuration is required:

[system services web-management]

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was discovered during a external security research.

This issue has been assigned CVE-2021-0210.

Solution:

The following software releases have been updated to resolve this specific issue: 12.3R12-S17, 15.1R7-S8, 17.3R3-S10, 17.4R2-S12, 17.4R3-S3, 18.1R3-S11, 18.2R3-S6, 18.3R2-S4, 18.3R3-S4, 18.4R2-S5, 18.4R3-S5, 19.1R1-S6, 19.1R2-S2, 19.1R3-S3, 19.2R1-S5, 19.2R3, 19.2R3-S1, 19.3R2-S4, 19.3R3, 19.4R1-S3, 19.4R2-S2, 19.4R3, 20.1R1-S4, 20.1R2, 20.2R1-S1, 20.2R2, 20.3R1, and all subsequent releases.

This issue is being tracked as 1518212.

Workaround:

There are no known workarounds for this issue.
 

Implementation:
Software releases or updates are available for download at https://www.juniper.net/support/downloads/.
Modification History:
2021-01-13: Initial Publication.
CVSS Score:
6.8 (CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N)
Severity Level:
Medium
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."
Acknowledgements:
Lena David and Geoffrey Bertoli of Synacktiv (https://synacktiv.com)

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search