Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2021-01 Security Bulletin: Junos OS: Command injection vulnerability in 'request system software' CLI command (CVE-2021-0219)

0

0

Article ID: JSA11109 SECURITY_ADVISORIES Last Updated: 13 Jan 2021Version: 1.0
Product Affected:
This issue affects all versions of Junos OS.
Problem:

A command injection vulnerability in install package validation subsystem of Juniper Networks Junos OS that may allow a locally authenticated attacker with privileges to execute commands with root privilege. To validate a package in Junos before installation, an administrator executes the command 'request system software add validate-on-host' via the CLI. An attacker with access to this CLI command may be able to exploit this vulnerability.

This issue affects Juniper Networks Junos OS:

  • all versions prior to 17.3R3-S10;
  • 17.4 versions prior to 17.4R2-S12, 17.4R3-S3;
  • 18.1 versions prior to 18.1R3-S11;
  • 18.2 versions prior to 18.2R2-S8, 18.2R3-S6;
  • 18.3 versions prior to 18.3R3-S4;
  • 18.4 versions prior to 18.4R1-S8, 18.4R2-S7, 18.4R3-S6;
  • 19.1 versions prior to 19.1R1-S6, 19.1R2-S2, 19.1R3-S3;
  • 19.2 versions prior to 19.2R3-S1;
  • 19.3 versions prior to 19.3R2-S5, 19.3R3-S1;
  • 19.4 versions prior to 19.4R2-S2, 19.4R3-S1;
  • 20.1 versions prior to 20.1R2;
  • 20.2 versions prior to 20.2R1-S2, 20.2R2;
  • 20.3 versions prior to 20.3R1-S1, 20.3R2.


Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was discovered during external security research.

This issue has been assigned CVE-2021-0219.
 

Solution:

The following software releases have been updated to resolve this specific issue:

Junos OS: 17.3R3-S10, 17.4R2-S12, 17.4R3-S3, 18.1R3-S11, 18.2R2-S8, 18.2R3-S6, 18.2X75-D34, 18.3R3-S4, 18.4R1-S8, 18.4R2-S7, 18.4R3-S6, 19.1R1-S6, 19.1R2-S2, 19.1R3-S3, 19.2R3-S1, 19.3R2-S5, 19.3R3-S1, 19.4R2-S2, 19.4R3-S1, 20.1R2, 20.2R1-S2, 20.2R2, 20.3R1-S1, 20.3R2, 20.4R1, and all subsequent releases.

This issue is being tracked as 1519337.
 

Workaround:

Use access lists or firewall filters to limit CLI access to the device only from trusted, administrative networks or hosts.

Limit access to the Junos OS CLI to only trusted system administrators.

Restrict access to the 'request system software add validate-on-host' command.
 

Implementation:
Software releases or updates are available for download at https://www.juniper.net/support/downloads/.
 
Modification History:
2021-01-13: Initial Publication.

CVSS Score:
6.7 (CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H)
Severity Level:
Medium
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."
Acknowledgements:
Juniper SIRT would like to acknowledge and thank Hoàng Thạch Nguyễn (d4rkn3ss) of STAR Labs for responsibly reporting this vulnerability.
 

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search