Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2021-10 Security Bulletin: Junos OS: SRX Series: The flowd process will crash if log session-close is configured and specific traffic is received (CVE-2021-31364)

0

0

Article ID: JSA11226 SECURITY_ADVISORIES Last Updated: 13 Oct 2021Version: 3.0
Product Affected:
This issue affects all versions of Junos OS. Affected platforms: SRX1500, SRX300 Series, SRX500 Series, and SRX5000 Series with SPC2.
Problem:

An Improper Check for Unusual or Exceptional Conditions vulnerability combined with a Race Condition in the flow daemon (flowd) of Juniper Networks Junos OS on SRX300 Series, SRX500 Series, SRX1500, and SRX5000 Series with SPC2 allows an unauthenticated network based attacker sending specific traffic to cause a crash of the flowd/srxpfe process, responsible for traffic forwarding in SRX, which will cause a Denial of Service (DoS).

Continued receipt and processing of this specific traffic will create a sustained Denial of Service (DoS) condition.

This issue can only occur when specific packets are trying to create the same session and logging for session-close is configured as a policy action.

Affected platforms are: SRX300 Series, SRX500 Series, SRX1500, and SRX5000 Series with SPC2. Not affected platforms are: SRX4000 Series, SRX5000 Series with SPC3, and vSRX Series.

This issue affects Juniper Networks Junos OS SRX300 Series, SRX500 Series, SRX1500, and SRX5000 Series with SPC2:

  • All versions prior to 17.4R3-S5;
  • 18.3 versions prior to 18.3R3-S5;
  • 18.4 versions prior to 18.4R3-S9;
  • 19.1 versions prior to 19.1R3-S6;
  • 19.2 versions prior to 19.2R1-S7, 19.2R3-S2;
  • 19.3 versions prior to 19.3R2-S6, 19.3R3-S2;
  • 19.4 versions prior to 19.4R1-S4, 19.4R3-S3;
  • 20.1 versions prior to 20.1R2-S2, 20.1R3;
  • 20.2 versions prior to 20.2R3;
  • 20.3 versions prior to 20.3R2-S1, 20.3R3;
  • 20.4 versions prior to 20.4R2.

This issue can only occur when logging for session-close is configured similar to the following example:

[security policies from-zone untrust to-zone trust policy policy_name then log session-close]

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was seen during production usage.

This issue has been assigned CVE-2021-31364.

Solution:

The following software releases have been updated to resolve this specific issue: 17.4R3-S5, 18.3R3-S5, 18.4R3-S9, 19.1R3-S6, 19.2R1-S7, 19.2R3-S2, 19.3R2-S6, 19.3R3-S2, 19.4R1-S4, 19.4R3-S3, 20.1R2-S2, 20.1R3, 20.2R3, 20.3R2-S1, 20.3R3, 20.4R2, 21.1R1, and all subsequent releases.

This issue is being tracked as 1571354.

Workaround:
Please remove the session-close log action from the policy actions of all policies.
Implementation:
Software releases or updates are available for download at https://support.juniper.net/support/downloads/
Modification History:
2021-10-13: Initial Publication.
CVSS Score:
5.9 (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H)
Severity Level:
Medium
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search