Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2021-10 Security Bulletin: Junos OS: PTX Series: An FPC heap memory leak will be triggered by certain Flowspec route operations which can lead to an FPC crash (CVE-2021-31367)

0

0

Article ID: JSA11229 SECURITY_ADVISORIES Last Updated: 13 Oct 2021Version: 2.0
Product Affected:
This issue affects all versions of Junos OS. Affected platforms: PTX Series.
Problem:

A Missing Release of Memory after Effective Lifetime vulnerability in the Packet Forwarding Engine (PFE) of Juniper Networks Junos OS on PTX Series allows an adjacent attacker to cause a Denial of Service (DoS) by sending genuine BGP flowspec packets which cause an FPC heap memory leak. Once having run out of memory the FPC will crash and restart along with a core dump.

Continued receipted of these packets will create a sustained Denial of Service (DoS) condition.

This issue affects Juniper Networks Junos OS on PTX Series:

  • All versions prior to 18.4R3-S9;
  • 19.1 versions prior to 19.1R3-S7;
  • 19.2 versions prior to 19.2R1-S7, 19.2R3-S3;
  • 19.3 versions prior to 19.3R2-S6, 19.3R3-S3;
  • 19.4 versions prior to 19.4R1-S4, 19.4R3-S6;
  • 20.1 versions prior to 20.1R2-S2, 20.1R3;
  • 20.2 versions prior to 20.2R3-S1;
  • 20.3 versions prior to 20.3R3;
  • 20.4 versions prior to 20.4R3;
  • 21.1 versions prior to 21.1R2.

Juniper Networks Junos Evolved is not affected.

This issue affects Junos OS devices with the BGP FlowSpec configured:

[procotol bgp ... family inet flow]

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was seen during production usage.

This issue has been assigned CVE-2021-31367.

Solution:

The following software releases have been updated to resolve this specific issue in Junos OS: 18.4R3-S9, 19.1R3-S7, 19.2R1-S7, 19.2R3-S3, 19.3R2-S6, 19.3R3-S3, 19.4R1-S4, 20.1R2-S2, 20.1R3, 20.2R3-S1, 20.3R3, 20.4R3, 21.1R2, 21.2R1, and all subsequent releases.

This issue is being tracked as 1589133.

Workaround:
There are no viable workarounds for this issue.
Implementation:
Software releases or updates are available for download at https://support.juniper.net/support/downloads/
Modification History:
2021-10-13: Initial Publication.
CVSS Score:
6.5 (CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
Severity Level:
Medium
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search