Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2021-10 Security Bulletin: Session Smart Router: Authentication Bypass Vulnerability (CVE-2021-31349)

0

0

Article ID: JSA11256 SECURITY_ADVISORIES Last Updated: 13 Oct 2021Version: 1.0
Product Affected:
This issue affects all Juniper Networks 128 Technology Session Smart Router versions prior to 4.5.11, and all versions of 5.0 up to and including 5.0.1.
Problem:

The usage of an internal HTTP header created an authentication bypass vulnerability (CWE-287), allowing an attacker to view internal files, change settings, manipulate services and execute arbitrary code.

This issue affects all Juniper Networks 128 Technology Session Smart Router versions prior to 4.5.11, and all versions of 5.0 up to and including 5.0.1.

This issue was discovered during external security research.

This issue has been assigned CVE-2021-31349.
 

Solution:
128 Technology has released software updates that address the vulnerability described in this advisory.

Fixed Releases:
The following 128T software patches have been released to resolve this specific issue: 4.5.11, 5.1.0, and all subsequent releases.

Customers who are running 5.0.0 or 5.0.1 should upgrade to 5.1.6 or later.

This issue is being tracked as I95-41227.
 
Workaround:

While no workarounds exist for this vulnerability, risk exposure can be mitigated. HTTP access to the SSR occurs on TCP port 443. It is recommended to install firewall rules to permit access only from trusted IP addresses.
 

Implementation:
Instructions for upgrading the 128T Networking Platform can be found at https://docs.128technology.com/docs/intro_upgrading .
Modification History:
2021-10-13: Initial Publication.

CVSS Score:
9.8 (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)
Severity Level:
Critical
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."
Acknowledgements:
128 Technology was notified via the JVN community of the vulnerability as JVN#85073657.
 

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search