Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2022-01 Security Bulletin: Junos OS: An rpd core will occur if BGP update tracing is configured and an update containing a malformed BGP SR-TE policy tunnel attribute is received (CVE-2022-22166)

0

0

Article ID: JSA11274 SECURITY_ADVISORIES Last Updated: 12 Jan 2022Version: 2.0
Product Affected:
This issue affects Junos OS 20.4, 21.1.
Problem:

An Improper Validation of Specified Quantity in Input vulnerability in the routing protocol daemon (rpd) of Juniper Networks Junos OS allows an unauthenticated networked attacker to cause an rdp crash and thereby a Denial of Service (DoS).

If a BGP update message is received over an established BGP session where a BGP SR-TE policy tunnel attribute is malformed and BGP update tracing flag is enabled, the rpd will core. This issue can happen with any BGP session as long as the previous conditions are met. This issue can not propagate as the crash occurs as soon as the malformed update is received.

This issue affects Juniper Networks Junos OS:

  • 20.4 versions prior to 20.4R3-S1;
  • 21.1 versions prior to 21.1R2-S2, 21.1R3.

This issue does not affect Juniper Networks Junos OS versions prior to 20.4R1.

The following two configuration lines are both required for the issue to be seen:

[ protocols bgp ... family <family> segment-routing-te ]
[ protocols bgp ... traceoptions flag update ]

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was seen during production usage.

This issue has been assigned CVE-2022-22166.

Solution:

The following software releases have been updated to resolve this specific issue: 20.4R3-S1, 21.1R2-S2, 21.1R3, 21.2R1, and all subsequent releases.

This issue is being tracked as 1598850.

Workaround:

Please remove the BGP update trace configuration that's applicable.

[ protocols bgp ... traceoptions flag update ]
Implementation:
Software releases or updates are available for download at https://support.juniper.net/support/downloads/
Modification History:
2022-01-12: Initial Publication.
CVSS Score:
6.5 (CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
Severity Level:
Medium
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search