Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

2022-01 Security Bulletin: Junos OS: vMX and MX150: Specific packets might cause a memory leak and eventually an FPC reboot (CVE-2022-22168)

0

0

Article ID: JSA11275 SECURITY_ADVISORIES Last Updated: 12 Jan 2022Version: 1.0
Product Affected:
This issue affects all versions of Junos OS. Affected platforms: vMX and MX150.
Problem:

An Improper Validation of Specified Type of Input vulnerability in the kernel of Juniper Networks Junos OS allows an unauthenticated adjacent attacker to trigger a Missing Release of Memory after Effective Lifetime vulnerability. Continued exploitation of this vulnerability will eventually lead to an FPC reboot and thereby a Denial of Service (DoS).

This issue affects:

Juniper Networks Junos OS on vMX and MX150:

  • All versions prior to 19.2R1-S8, 19.2R3-S4;
  • 19.3 versions prior to 19.3R3-S5;
  • 19.4 versions prior to 19.4R2-S5, 19.4R3-S6;
  • 20.1 versions prior to 20.1R3-S2;
  • 20.2 versions prior to 20.2R3-S3;
  • 20.3 versions prior to 20.3R3-S1;
  • 20.4 versions prior to 20.4R3;
  • 21.1 versions prior to 21.1R2-S1, 21.1R3;
  • 21.2 versions prior to 21.2R1-S1, 21.2R2;
  • 21.3 versions prior to 21.3R1-S1, 21.3R2.

Juniper SIRT is not aware of any malicious exploitation of this vulnerability.

This issue was seen during production usage.

This issue has been assigned CVE-2022-22168.

Solution:

The following software releases have been updated to resolve this specific issue: 19.2R1-S8, 19.2R3-S4, 19.4R2-S5, 19.4R3-S6, 20.1R3-S2, 20.2R3-S3, 20.3R3-S1, 20.4R3, 21.1R2-S1, 21.1R3, 21.2R1-S1, 21.2R2, 21.2R3, 21.3R1-S1, 21.3R2, 21.4R1, and all subsequent releases.

This issue is being tracked as 1599158.

Workaround:
There is no viable workaround for this issue.
Implementation:
Software releases or updates are available for download at https://support.juniper.net/support/downloads/
Modification History:
2022-01-12: Initial Publication.
CVSS Score:
6.5 (CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)
Severity Level:
Medium
Severity Assessment:
Information for how Juniper Networks uses CVSS can be found at KB 16446 "Common Vulnerability Scoring System (CVSS) and Juniper's Security Advisories."

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search