Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

While trying to Install SBR 7.2 on a Standalone Platform, it throws DCF Error Messages and end users cannot start SBR.

0

0

Article ID: KB14778 KB Last Updated: 05 Mar 2017Version: 3.0
Summary:

A log error of "RADIUS: system. log: message: unknown failure in attempt to convert program id to class id" could indicate a OS compatibility issue.  What is the minimum Solaris OS requirements for installing SBR 7.2 on a Standalone Platform?

Symptoms:
While trying to Install SBR 7.2 on a Standalone Platform, DCF Error Messages are displayed.  The log only shows “RADIUS: system. log: message: unknown failure in attempt to convert program id to class id”.  The end user cannot start the SBR even if the installation was successful.


Solution:
In general, the message "RADIUS: system. log: message: unknown failure in attempt to convert program id to class id" indicates that some DCF library is incompatible with the installed version of SBR. This may occur when a bad build or patch is installed, or when the DCF library itself is incompatible with the OS version.  In the particular case of SBR 7.2.0 this message is very strongly associated with attempts to install the software on an insufficient OS version.  At least Solaris 10 8/07 is required.  Also note that it is not always possible to patch an older Solaris 10 into a newer version. Sometimes a new install is required.

It is advised to check the version of Solaris with the commands "uname -a" and "cat /etc/release". The "Generic_XXXXXX-XX" part of "uname -a" output indicates the kernel patch that is installed.  Generic means it is not a special purpose kernel and XXXXXX-XX is a standard Solaris patch number.  In general, but not always, higher patch numbers are more recent and thus "better" than lower patch numbers.  Solaris 10 8/07 has Generic_120011-14.  It is strongly advised to apply at least this patch number or better.
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search