Support Support Downloads Knowledge Base Apex Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[Junos] Configuration example: IS-IS adjacency between Cisco and Juniper

0

0

Article ID: KB20097 KB Last Updated: 27 May 2011Version: 1.0
Summary:
This article shows the configuration that is needed to get an IS-IS adjacency between a Cisco and Juniper router to come up.  A simple lab test and the results are shown in this article. 

REFERENCE - JNCIS STUDY GUIDE PAGE 169:
"Each interface in an IS-IS network must support a maximum transmission unit (MTU) of 1492 bytes. To verify this support, each IS-IS router pads its Hello PDUs to the maximum MTU size. Should an interface not support 1492 bytes’ worth of data payload, the PDU is not received by the neighbor and the adjacency is not established."

Symptoms:
The goal is to get the IS-IS adjacency up. The problem is caused by a MTU mismatch between the Cisco and Juniper routers.
Solution:

Topology:

Cisco7200---4/0-ge-1/0/2---JuniperT320

Junos version: 10.2R2.11
IOS version: 12.2(33)SRD3

Junos Configuration:

interfaces {
    ge-1/0/2 {
        unit 0 {
            family inet {
	        address 1.1.1.2/30;
	    }
	    family iso {
	        mtu 1490;
	    }
        }
    }
    lo0 {
        unit 0 {
	    family inet {
                address 192.168.1.1/32;
	    }
            family iso {
		address 49.0001.1920.1680.0001.0001.00;
	    }
	}
    }
}
protocols {
    isis {
	interface ge-1/0/2.0 {
	    level 1 disable;
	}
    }
}

IOS Configuration:

interface GigabitEthernet4/0
ip address 1.1.1.1 255.255.255.252
ip router isis
negotiation auto
dot1q tunneling ethertype 0x9100

RESULTS:

Juniper> show isis adjacency
Interface     System     L     State             Hold (secs) SNPA
ge-1/0/2.0  Cisco        2     Initializing    29 0:50:b:57:f4:70
It is stuck in initializing because the MTU is too small. Changing the family ISO MTU to 1492 will allow the ISIS adjacency to form:
Juniper# set interfaces ge-1/0/2 unit 0 family iso mtu 1492
Juniper# commit 
Juniper>show isis adjacency
Interface     System      L     State       Hold (secs) SNPA
ge-1/0/2.0   Cisco        2      Up          9 0:50:b:57:f4:70

Cisco# show isis neighbors
System     Id     Type     Interface IP Address      State     Holdtime Circuit Id
juniper      L2    Gi4/0    1.1.1.2                              UP        21 Cisco.02
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search