Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

NSM tasks such as update device, summarize delta config, or import device take a long time to complete due to the large size of the directive container (>1GB)

0

0

Article ID: KB22953 KB Last Updated: 15 Feb 2012Version: 1.0
Summary:
This article describes the issue of NSM tasks, such as update device, summarize delta config, and import device, taking a long time to complete. This is due to the large size of the directive container (>1GB).
Symptoms:
If there are a lot of old jobs stored in the NSM job manager, the currently running jobs can be quite slow, as each time a new job is run, the entire job database container needs to be loaded.

You can verify the size of the job container in the NSM database.

On the NSM CLI, log in as root :

#cd /var/netscreen/GuiSvr/xdb/data
#du –hs directive

If the size of the directive container is large ( say more than 1GB ), then there is a good chance that the jobs on NSM GUI might be slow to start.

Note: It is not guaranteed that following this article will improve the performance, as there are many other factors which might be responsible. This article discusses one of those factors.


Cause:
The old jobs stored in the NSM database take a long time to load. Whenever a new job is running, the Job manager has to load the entire Job container in the NSM database.
Solution:
  1. Remove the old jobs from the GUI; go to Administer > Job manager > delete.

  2. or

  3. Use the CLI to delete all the jobs in the job manager.

    1. Logon to the NSM CLi as the root user.

    2. Stop the NSM services (as per KB11263 - Proper order for starting and stopping NSM services):

      #cd /var/netscreen/GuiSvr/xdb/data/
      #rm –rf directive
      # cd /var/netscreen/GuiSvr/xdb/init/
      #rm –rf directive.init


    3. After the NSM services are stopped, the NSM database has to be exported/imported; for more information refer to KB11731 - How to Export and Import the NSM database in 2007.1r3 and higher to remove audit logs, old database versions or shrink the database

Note:

This article is applicable, only if the issue is seen across all domains on all the devices running all kinds of jobs, as it is an issue with the time taken in loading the job. it is not applicable in scenarios, where the issue is with running jobs on a single device.

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search