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[EOL/EOE] How to check if service objects can be applied to a particular device

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Article ID: KB24062 KB Last Updated: 10 Mar 2021Version: 3.0
Summary:
Note: A product listed in this article has either reached hardware End of Life (EOL) OR software End of Engineering (EOE).  Refer to End of Life Products & Milestones for the EOL, EOE, and End of Support (EOS) dates.
This article provides information on how to check if a service object can used with ScreenOS, SRX/J-series devices, or both.
Symptoms:
  • At times, it is unclear if an NSM pre-defined service object will work when applied to a policy for a JunOS or ScreenOS device.
  • Applying a service object to a device, for which it is not intended, will lead to warning errors.
Cause:

Service objects in NSM are defined with the intended platform (JunOS or ScreenOS) in mind.

Solution:
To properly apply a service object to a device, when used in a policy, it must contain the service definition for that platform (JunOS or ScreenOS). For example, if a user wants to apply the FTP service object in a policy, they can do so for either ScreenOS or JunOS devices.




But, for the SUN-RPC-TCP object, the service is defined only for Junos devices (J/SRX). So, a user cannot apply this object in a policy that will be used on a ScreenOS device.





The SUN-RPC-MOUNTD service is defined only for ScreenOS devices. So, this object cannot be used in a policy that will be applied to Junos devices.



You have to edit the service objects, which you want to use, to ensure that they can be used with the intended device platform. Alternatively, you can move the mouse cursor over the required service object and a pop-up window will describe the platforms, for which the object is recommended.

Examples:






 
Modification History:
2021-03-10: Tagged for EOL/EOE
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