Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[MX] The 'clksyncd' process has exceeded 85% of RLIMIT_DATA

0

0

Article ID: KB24673 KB Last Updated: 04 Mar 2021Version: 2.0
Summary:

This article describes the issue of the kernel: Process (35981,clksyncd) attempted to exceed RLIMIT_DATA: attempted xxxxx KB Max xxxxxx KB error message being generated, when running Junos OS code version 11.2R3.

Symptoms:
There is a memory leak in the clksyncd process, which occurs when the xe- links are flapping. The log messages are as follows:
kernel: Process (35981,clksyncd) attempted to exceed RLIMIT_DATA: attempted 131076 KB Max 131072 KB
kernel: Process (35981,clksyncd) attempted to exceed RLIMIT_DATA: attempted 131076 KB Max 131072 KB
kernel: Process (35981,clksyncd) attempted to exceed RLIMIT_DATA: attempted 131076 KB Max 131072 KB
kernel: Process (35981,clksyncd) attempted to exceed RLIMIT_DATA: attempted 131076 KB Max 131072 KB
sec=clksyncd: SIGTERM - clksyncd
init: clksyncd-service (PID 35981) exited with status=0 Normal Exit
init: clksyncd-service (PID 28110) started
kernel: Process (28110,clksyncd) has exceeded 85% of RLIMIT_DATA: used 114704 KB Max 131072 KB
kernel: Process (28110,clksyncd) has exceeded 85% of RLIMIT_DATA: used 115056 KB Max 131072 KB
kernel: Process (28110,clksyncd) has exceeded 85% of RLIMIT_DATA: used 115472 KB Max 131072 KB
Cause:
This issue is due to several interfaces having a large amount of framing errors:
Jun 5 22:19:56 router.test mib2d[1914]: SNMP_TRAP_LINK_DOWN: ifIndex 536, ifAdminStatus up(1), ifOperStatus down(2), ifName xe-0/3/2
Jun 5 22:20:19 router.test last message repeated 5 times
Jun 5 22:22:25 router.test last message repeated 14 times
Jun 5 22:23:16 router.test last message repeated 6 times

As you can see, the interfaces are flapping very fast.


To check the framing error :
# show interfaces xe-0/3/2 extensive | match "errors: |Carrier transitions"

Errors: 1451, Drops: 0, Framing errors: 1451, Runts: 0, Policed discards: 0, L3 incompletes: 0, L2 channel errors: 0, L2 mismatch timeouts: 0, FIFO errors: 0, Resource errors: 0, Carrier transitions: 31569, Errors: 0, Drops: 0, Collisions: 0, Aged packets: 0, FIFO errors: 0, HS link CRC errors: 0, MTU errors: 0, Resource errors: 0

There are a lot of framing errors and carrier transitions.
> show system processes extensive | match clksyncd
PID USERNAME THR PRI NICE SIZE RES STATE TIME WCPU COMMAND 45699 root 1 96 0 134M 131M select 0:17 0.00% clksyncd


> restart clksyncd-service Ethernet Clock Synchronization Process started, pid 37271
user@router.test> show system processes extensive | match clk 37271 root 1 96 0 6664K 3428K select 0:00 3.37% clksyncd
Solution:
To recover the memory, restart the process with restart clksyncd-service. Restarting this process will not affect the service and it will prevent it from reaching the limit and being unable to allocate memory.
Modification History:
2021-03-21: non-technical edit; corrected router name.
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search