Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[EOL/EOE] [NSM] Configuration changes made to log actions on any rule in the IDP rule base does not work

0

0

Article ID: KB24701 KB Last Updated: 18 Oct 2020Version: 2.0
Summary:
Note: A product listed in this article has either reached hardware End of Life (EOL) OR software End of Engineering (EOE).  Refer to End of Life Products & Milestones for the EOL, EOE, and End of Support (EOS) dates.
This article describes the issue of any configuration change, when made to the IDP rule base for any rule under the Notifications column > logging > log actions, not taking effect; without an update push.
Symptoms:
A Configuration change made to log actions on any rule in the IDP rule base does not take effect.
Cause:
Log actions, which are defined in the policy, must be updated to the device.
Solution:
  • After any configuration change in the IDP rule base for any rule under Notifications column > logging > log actions, the update has to be pushed to the device; irrespective of the device being a stand-alone IDP, SRX-IDP, or ISG-IDP device.

  • Generally, such configuration changes do not require a device update; as this is NSM specific.

  • But, in case of IDP rule bases, when the log comes in from the IDP device, it uses a different table; other than the usual rb_idp table.

  • This is not the case with other rule bases (other than IDP), as they refer to rule base tables, such as the rb_firewall container in xdb.

  • The changes, when saved in log actions for any rule, are directly applied. No update push is required for other rule bases.
Modification History:
2020-10-18: Tagged article for EOL/EOE.
 
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search