Support Support Downloads Knowledge Base Apex Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

Understanding the effects of ISIS wide-metric-only and traffic-engineering disable configuration options in Junos

0

0

Article ID: KB25145 KB Last Updated: 24 Aug 2012Version: 1.0
Summary:
This article provides information about the effects of ISIS wide-metrics-only and traffic-engineering disable configuration options in Junos.
Symptoms:
  • When ISIS wide-metrics-only is configured for a level or interface, TLV`s 2 and 128 are suppressed from being sent by the local router.

  • When ISIS Traffic Engineering is disabled, TLV`s 22, 134, and 135 are suppressed from being sent.

  • The combination of wide-metrics-only and traffic-engineering disable under protocols ISIS will result in the total loss of ISIS routing information for that level.

  • This combination suppresses TLV`s 2, 22, 128, 134, and 135 from being sent.
Cause:

Solution:
This topology will be used to portray the effects of the ISIS wide-metrics-only and traffic-engineering disable configuration options, with careful attention to the TLV`s 2, 22, 134, and 135. The effect of the configuration options on TLv`s 2, 22, 128, 134, and 135 will be individually evaluated.

Topology:

r1 and r2 are logical systems on the black router:
lo0 192.168.1.1                  lo0 192.168.1.2
     +---------+                      +---------+
     |         +----------------------+         |
     |  r1     |ge-0/2/0      ge-0/2/1|   r2    |
     +---------+10.1.2.1      10.1.2.2+---------+
TLV name 						TLV # 		PDU 

IS Reachability 				2 			L1 LSP, L2 LSP  < TLV : Old style TLV
Extended IS Reachability 			22 			L1 LSP, L2 LSP	< TLV : New style TLV
IP Internal Reachability 			128 			L1 LSP, L2 LSP  < TLV : Old style TLV
Traffic Engineering IP(Router ID)	134			L1 LSP, L2 LSP
Extended IP Reachability 			135 			L1 LSP, L2 LSP < TLV : New style TLV
Base configuration:
[edit]
lab@black# show logical-systems r1
Jun 23 15:27:35
interfaces {
    ge-0/2/0 {
        unit 0 {
            family inet {
                address 10.1.2.1/24;
            }
            family iso;
        }
    }
    lo0 {
        unit 1 {
            family inet {
                address 192.168.1.1/32;
            }
            family iso {
                address 49.0190.0192.0168.0101.00;
            }
        }
    }
}
protocols {
    isis {
        level 1;
        interface all {
            level 2 disable;
        }
    }
}
routing-options {
    router-id 192.168.1.1;
}

[edit]
lab@black# show logical-systems r2    
Jun 23 15:27:57
interfaces {
    ge-0/2/1 {
        unit 0 {
            family inet {
                address 10.1.2.2/24;
            }
            family iso;
        }
    }
    lo0 {
        unit 2 {
            family inet {
                address 192.168.1.2/32;
            }
            family iso {
                address 49.0190.0192.0168.0102.00;
            }
        }
    }
}
protocols {
    isis {
        level 1;
        interface all {
            level 2 disable;
        }
    }
}
routing-options {
    router-id 192.168.1.2;
}
Case 1 - Base configuration:

  • By default, traffic engineering is enabled in Junos for the ISIS protocols.

  • By default, Junos generates and accepts both wide and narrow style TLV`s.


Outputs:
[edit]
lab@black# run show isis adjacency logical-system r1     
Jun 23 15:29:46
Interface             System         L State        Hold (secs) SNPA
ge-0/2/0.0            black-r2       1  Up                    8  0:1b:c0:89:34:3f

-----

lab@black# run show isis route logical-system r1 
Jun 23 15:29:28
 IS-IS routing table             Current version: L1: 5 L2: 5
IPv4/IPv6 Routes
----------------
Prefix             L Version   Metric Type Interface    Via
192.168.1.2/32     1       5       10 int  ge-0/2/0.0   black-r2
ISIS database:
[edit]
lab@black# run show isis database logical-system r1 extensive level 1 
Jun 23 15:30:30
IS-IS level 1 link-state database:

black-r1.00-00 Sequence: 0x9, Checksum: 0x321, Lifetime: 1082 secs
   IS neighbor: black-r2.02                   Metric:       10
   IP prefix: 10.1.2.0/24                     Metric:       10 Internal Up
   IP prefix: 192.168.1.1/32                  Metric:        0 Internal Up

  Header: LSP ID: black-r1.00-00, Length: 147 bytes
    Allocated length: 1492 bytes, Router ID: 192.168.1.1
    Remaining lifetime: 1082 secs, Level: 1, Interface: 0
    Estimated free bytes: 1293, Actual free bytes: 1345
    Aging timer expires in: 1082 secs
    Protocols: IP, IPv6

  Packet: LSP ID: black-r1.00-00, Length: 147 bytes, Lifetime : 1198 secs
    Checksum: 0x321, Sequence: 0x9, Attributes: 0x3 <L1 L2>
    NLPID: 0x83, Fixed length: 27 bytes, Version: 1, Sysid length: 0 bytes
    Packet type: 18, Packet version: 1, Max area: 0
TLVs:
Area address: 49.0190 (3)
Speaks: IP
Speaks: IPV6
IP router id: 192.168.1.1
IP address: 192.168.1.1
Hostname: black-r1
IS neighbor: black-r2.02, Internal, Metric: default 10 < TLV : Old style TLV 
IS extended neighbor: black-r2.02, Metric: default 10 < TLV : New style TLV
IP address: 10.1.2.1
Local interface index: 69,
Remote interface index: 0
IP prefix: 10.1.2.0/24, Internal, Metric: default 10, Up
IP prefix: 192.168.1.1/32, Internal, Metric: default 0, Up
IP extended prefix: 10.1.2.0/24 metric 10 up
IP extended prefix: 192.168.1.1/32 metric 0 up
No queued transmissions
LSP capture:

TLVs 2,22,128,134,and 135 are all present.
lab@black# run monitor traffic interface ge-0/2/0 detail no-resolve
  
  15:36:58.015722 Out IS-IS, length 147
        L1 LSP, hlen: 27, v: 1, pdu-v: 1, sys-id-len: 6 (0), max-area: 3 (0)
          lsp-id: 0192.0168.0101.00-00, seq: 0x0000000b, lifetime:  1198s
          chksum: 0xfe23 (correct), PDU length: 147, Flags: [ L1L2 IS ]
            Area address(es) TLV #1, length: 4
              Area address (length: 3): 49.0190
            Protocols supported TLV #129, length: 2
              NLPID(s): IPv4 (0xcc), IPv6 (0x8e)
            Traffic Engineering Router ID TLV #134, length: 4
Traffic Engineering Router ID: 192.168.1.1 IPv4 Interface address(es) TLV #132, length: 4 IPv4 interface address: 192.168.1.1 Hostname TLV #137, length: 8 Hostname: black-r1 IS Reachability TLV #2, length: 12 IsNotVirtual IS Neighbor: 0192.0168.0102.02, Default Metric: 10, Internal Extended IS Reachability TLV #22, length: 27 IS Neighbor: 0192.0168.0102.02, Metric: 10, sub-TLVs present (16) IPv4 interface address subTLV #6, length: 4, 10.1.2.1 Link Local/Remote Identifier subTLV #4, length: 8, 0x00000045, 0x00000000 IPv4 Internal Reachability TLV #128, length: 24 IPv4 prefix: 10.1.2.0/24, Distribution: up, Metric: 10, Internal IPv4 prefix: 192.168.1.1/32, Distribution: up, Metric: 0, Internal Extended IPv4 Reachability TLV #135, length: 17 IPv4 prefix: 10.1.2.0/24, Distribution: up, Metric: 10 IPv4 prefix: 192.168.1.1/32, Distribution: up, Metric: 0
Case 2 - wide-metrics-only configured:

When wide-metrics-only is configured for a level, Junos suppresses the generation of narrow-style-metric TLV`s.
[edit]
lab@black# show logical-systems r1 protocols isis 
Jun 23 15:41:47
protocols {
    isis {
        level 1 wide-metrics-only; < Configured 
        interface all {
            level 2 disable;
        }
    }
}
Outputs:

Routing information:
[edit]
lab@black# run show isis route logical-system r1 
Jun 23 15:55:55
 IS-IS routing table             Current version: L1: 11 L2: 14
IPv4/IPv6 Routes
----------------
Prefix             L Version   Metric Type Interface    Via
192.168.1.2/32     1      11       10 int  ge-0/2/0.0   black-r2   

[edit]
lab@black# run show isis spf results logical-system r1    
Jun 23 16:06:16
 IS-IS level 1 SPF results:
Node             Metric     Interface         Via             SNPA
black-r2.00      10         ge-0/2/0.0       black-r2        0:1b:c0:89:34:3f
                 20         10.1.2.0/24
                 10         192.168.1.2/32        

[edit]
lab@black#
ISIS database:
[edit]
lab@black# run show isis database logical-system r1 level 1 extensive 
Jun 23 15:47:32
IS-IS level 1 link-state database:

black-r1.00-00 Sequence: 0xd, Checksum: 0xbd1c, Lifetime: 807 secs
   IS neighbor: black-r2.02                   Metric:       10
   IP prefix: 10.1.2.0/24                     Metric:       10 Internal Up
   IP prefix: 192.168.1.1/32                  Metric:        0 Internal Up

  Header: LSP ID: black-r1.00-00, Length: 107 bytes
    Allocated length: 1492 bytes, Router ID: 192.168.1.1
    Remaining lifetime: 807 secs, Level: 1, Interface: 0
    Estimated free bytes: 1329, Actual free bytes: 1385
    Aging timer expires in: 807 secs
    Protocols: IP, IPv6

  Packet: LSP ID: black-r1.00-00, Length: 107 bytes, Lifetime : 1198 secs
    Checksum: 0xbd1c, Sequence: 0xd, Attributes: 0x3 <L1 L2>
    NLPID: 0x83, Fixed length: 27 bytes, Version: 1, Sysid length: 0 bytes
    Packet type: 18, Packet version: 1, Max area: 0
TLVs:
Area address: 49.0190 (3)
    Speaks: IP
    Speaks: IPV6
    IP router id: 192.168.1.1
    IP address: 192.168.1.1
    Hostname: black-r1
    IS extended neighbor: black-r2.02, 
Metric: default 10 IP address: 10.1.2.1
Local interface index: 69,
Remote interface index: 0
IP extended prefix: 10.1.2.0/24 metric 10 up IP
extended prefix: 192.168.1.1/32 metric 0 up
No queued transmissions
LSP capture:

Note:

  • Compared to the previous LSP output, TLV 2 and TLV 128 are missing, as the wide-metrics-only option is enabled. TLV`s corresponding to the narrow (old style) metric are suppressed

  • 'Suppressed' indicates that the local router, which is configured for wide-metric, does not send TLVs 2 and 128; but accepts them, if received.
lab@black# run monitor traffic interface ge-0/2/0 detail no-resolve

15:41:01.016672 Out IS-IS, length 107
        L1 LSP, hlen: 27, v: 1, pdu-v: 1, sys-id-len: 6 (0), max-area: 3 (0)
          lsp-id: 0192.0168.0101.00-00, seq: 0x0000000d, lifetime:  1198s
          chksum: 0xbd1c (correct), PDU length: 107, Flags: [ L1L2 IS ]
            Area address(es) TLV #1, length: 4
              Area address (length: 3): 49.0190
            Protocols supported TLV #129, length: 2
              NLPID(s): IPv4 (0xcc), IPv6 (0x8e)
            Traffic Engineering Router ID TLV #134, length: 4
              Traffic Engineering Router ID: 192.168.1.1
            IPv4 Interface address(es) TLV #132, length: 4
              IPv4 interface address: 192.168.1.1
            Hostname TLV #137, length: 8									
              Hostname: black-r1
            Extended IS Reachability TLV #22, length: 27
              IS Neighbor: 0192.0168.0102.02, Metric: 10, sub-TLVs present (16)
                IPv4 interface address subTLV #6, length: 4, 10.1.2.1
                Link Local/Remote Identifier subTLV #4, length: 8, 0x00000045, 0x00000000
            Extended IPv4 Reachability TLV #135, length: 17
              IPv4 prefix:        10.1.2.0/24, Distribution: up, Metric: 10
              IPv4 prefix:     192.168.1.1/32, Distribution: up, Metric: 0
Case 3 - traffic-engineering disabled:
lab@black# show logical-systems r1 protocols isis 
Jun 25 15:43:43
traffic-engineering disable; < Configured 
interface ge-0/2/0.0;
interface lo0.1;
interface all {
    level 2 disable;
}
Routing information:
[edit]
lab@black# run show isis route logical-system r1 
Jun 25 15:44:53
 IS-IS routing table             Current version: L1: 247 L2: 261
IPv4/IPv6 Routes
----------------
Prefix             L Version   Metric Type Interface    Via
192.168.1.2/32     1     247       10 int  ge-0/2/0.0   black-r2
ISIS database:
[edit]
lab@black# run show isis database extensive logical-system r1 
Jun 25 15:45:25
IS-IS level 1 link-state database:

black-r1.00-00 Sequence: 0x102, Checksum: 0xe439, Lifetime: 1087 secs
   IS neighbor: black-r2.02                   Metric:       10
   IP prefix: 10.1.2.0/24                     Metric:       10 Internal Up
   IP prefix: 192.168.1.1/32                  Metric:        0 Internal Up

  Header: LSP ID: black-r1.00-00, Length: 87 bytes
    Allocated length: 1492 bytes, Router ID: 0.0.0.0
    Remaining lifetime: 1087 secs, Level: 1, Interface: 0
    Estimated free bytes: 1345, Actual free bytes: 1405
    Aging timer expires in: 1087 secs
    Protocols: IP, IPv6

  Packet: LSP ID: black-r1.00-00, Length: 87 bytes, Lifetime : 1198 secs
    Checksum: 0xe439, Sequence: 0x102, Attributes: 0x3 <L1 L2>
    NLPID: 0x83, Fixed length: 27 bytes, Version: 1, Sysid length: 0 bytes
    Packet type: 18, Packet version: 1, Max area: 0
TLVs:
    Area address: 49.0190 (3)
    Speaks: IP
    Speaks: IPV6
    Hostname: black-r1
    IS neighbor: black-r2.02,Internal, 
Metric: default 10
IP prefix: 10.1.2.0/24, Internal, Metric: default 10, Up
IP prefix: 192.168.1.1/32,
Internal, Metric: default 0, Up
No queued transmissions
TED database:
[edit]
lab@black# run show ted database extensive logical-system r1 
Jun 25 15:45:56
TED database: 0 ISIS nodes 0 INET nodes
LSP capture:

TLVs 22,134, and 135 are suppressed and not sent; which indirectly suppresses the wide-style metric TLV`s.
[edit]
lab@black# run monitor traffic interface ge-0/2/0 detail no-resolve

15:47:00.137512 Out IS-IS, length 87
L1 LSP, hlen: 27, v: 1, pdu-v: 1, sys-id-len: 6 (0), max-area: 3 (0)
lsp-id: 0192.0168.0101.00-00, seq: 0x00000104, lifetime: 1198s
chksum: 0xe03b (correct), PDU length: 87, Flags: [ L1L2 IS ]
Area address(es) TLV #1, length: 4
Area address (length: 3): 49.0190
Protocols supported TLV #129, length: 2
NLPID(s): IPv4 (0xcc), IPv6 (0x8e)
Hostname TLV #137, length: 8
Hostname: black-r1
IS Reachability TLV #2, length: 12
IsNotVirtual
IS Neighbor: 0192.0168.0102.02, Default Metric: 10, Internal
IPv4 Internal Reachability TLV #128, length: 24
IPv4 prefix: 10.1.2.0/24, Distribution: up, Metric: 10, Internal
IPv4 prefix: 192.168.1.1/32, Distribution: up, Metric: 0, Internal
Case 4 - wide-metrics-only is configured and traffic-engineering is disabled:
[edit]
lab@black# show logical-systems r1 protocols isis 
Jun 23 15:53:54
traffic-engineering disable; < Configured 
level 1 wide-metrics-only; < Configured 
interface all {
    level 2 disable;
}
Outputs:

Routing information:
[edit]
lab@black# run show isis route logical-system r1 
Jun 23 15:55:17
 IS-IS routing table Current version: L1: 10 L2: 12 < No routes 
[edit]
lab@black#

lab@black# run show isis spf results logical-system r1 
Jun 23 16:05:17
 IS-IS level 1 SPF results:
Node             Metric     Interface         Via             SNPA
black-r2.00      <disconnected>	
black-r1.00      0
  2 nodes
ISIS database:
[edit]
lab@black# run show isis database logical-system r1 extensive 
Jun 25 15:12:29
IS-IS level 1 link-state database:

black-r1.00-00 Sequence: 0xfb, Checksum: 0xd707, Lifetime: 1187 secs

  Header: LSP ID: black-r1.00-00, Length: 47 bytes
    Allocated length: 1492 bytes, Router ID: 0.0.0.0
    Remaining lifetime: 1187 secs, Level: 1, Interface: 0
    Estimated free bytes: 1381, Actual free bytes: 1445
    Aging timer expires in: 1187 secs
    Protocols: IP, IPv6

  Packet: LSP ID: black-r1.00-00, Length: 47 bytes, Lifetime : 1198 secs
    Checksum: 0xd707, Sequence: 0xfb, Attributes: 0x3 <L1 L2>
    NLPID: 0x83, Fixed length: 27 bytes, Version: 1, Sysid length: 0 bytes
    Packet type: 18, Packet version: 1, Max area: 0
TLVs:
Area address: 49.0190 (3)
    Speaks: IP
    Speaks: IPV6
    Hostname: black-r1
  No queued transmissions
LSP capture:

Note:

  • TLV`s 2, 22, 128, 134, and 135 are suppressed from being sent.

  • Essentially, no IP prefix and IS neighbor information are exchanged.

  • So, the routing information is not available.
lab@black# run monitor traffic interface ge-0/2/0 detail no-resolve

15:57:38.143900 Out IS-IS, length 47
        L1 LSP, hlen: 27, v: 1, pdu-v: 1, sys-id-len: 6 (0), max-area: 3 (0)
          lsp-id: 0192.0168.0101.00-00, seq: 0x00000012, lifetime:  1198s
          chksum: 0xab1d (correct), PDU length: 47, Flags: [ L1L2 IS ]
            Area address(es) TLV #1, length: 4
              Area address (length: 3): 49.0190
            Protocols supported TLV #129, length: 2
              NLPID(s): IPv4 (0xcc), IPv6 (0x8e)
            Hostname TLV #137, length: 8
              Hostname: black-r1
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search