Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[SRX] PPPoA configuration example

0

0

Article ID: KB25400 KB Last Updated: 27 Mar 2020Version: 3.0
Summary:

This article provides an example of the Point-to-Point over ATM (PPPoA) configuration.

Solution:

Configuration for the at-1/0/0 interface:

at-1/0/0 { 
		description ADSL; 
		encapsulation atm-pvc; 
		atm-options { 
			vpi [vpi number]; 
		} 
		dsl-options { 
			operating-mode auto; 
		} 
		unit 0 { 
			description PPPoA; 
			encapsulation atm-ppp-vc-mux; 
			vci ([vpi number].[vci number]); 
			ppp-options {
				chap {
					access-profile (access-profile-name);
					passive;
				} 
				pap {
					default-password (password provided by the service-provider); 
					local-name (user-id provided by the service-provider); 
					local-password (password provided by the service-provider); 
					passive; 
				}
			}
			family inet {
				address (static IP provided by the service-provider);
			}
		}
    } 

Access configuration for chap:

    access {
		profile (access-profile-name){
			client (user-id provided by the service-provider) 
chap-secret (password provided by the service-provider);
		}
	}

Binding the at-1/0/0 interface to a zone:

    security-zone untrust {
         host-inbound-traffic {
            system-services {
                all; 
            } 
			protocols {
				all;
			}
        }
		interfaces { 
			at-1/0/0.0;
		}
    } 

Configure the default-route:

    user@host# show routing-options static {
		route 0.0.0.0/0 next-hop at-1/0/0.0;
    }

Corresponding set of commands for the configuration:

set interfaces at-1/0/0 description ADSL
set interfaces at-1/0/0 encapsulation atm-pvc
set interfaces at-1/0/0 atm-options vpi [vpi number]
set interfaces at-1/0/0 dsl-options operating-mode auto
set interfaces at-1/0/0 unit 0 description PPPoA
set interfaces at-1/0/0 unit 0 encapsulation atm-ppp-vc-mux
set interfaces at-1/0/0 unit 0 vci ([vpi number].[vci number])
set interfaces at-1/0/0 unit 0 ppp-options chap access-profile (access-profile-name)
set interfaces at-1/0/0 unit 0 ppp-options chap passive
set interfaces at-1/0/0 unit 0 ppp-options pap default-password (password provided by the service-provider)
set interfaces at-1/0/0 unit 0 ppp-options pap local-name (user-id provided by the service-provider)
set interfaces at-1/0/0 unit 0 ppp-options pap local-password (password provided by the service-provider)
set interfaces at-1/0/0 unit 0 ppp-options pap passive
set interfaces at-1/0/0 unit 0 family inet address (static IP provided by the service-provider)
set routing-options static route 0.0.0.0/0 next-hop at-1/0/0.0
set security zones security-zone untrust interfaces at-1/0/0.0 host-inbound-traffic system-services all
set security zones security-zone untrust interfaces at-1/0/0.0 host-inbound-traffic protocols all
set access profile (access-profile-name) client (user-id provided by the service-provider) chap-secret (password provided by the service-provider)
Modification History:

2020-03-27: Article reviewed for accuracy. Article is correct and complete.

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search