Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

The detection/fallback notification mail is not being sent from the SRX device

0

0

Article ID: KB26517 KB Last Updated: 26 Feb 2020Version: 2.0
Summary:
This article describes the issue of the notification mail not being sent from the SRX device to the mail sender, even though the notify-mail-sender is configured for virus detection or fallback-block.
 
Symptoms:

The following configuration is an example of notify-mail-sender for virus detection:

root@srx# show security utm feature-profile
anti-virus {
    type kaspersky-lab-engine;
    kaspersky-lab-engine {
        pattern-update {
        email-notify {
            admin-email "admin@example.com";
            custom-message "Pattern Updated";
            custom-message-subject "Pattern update done";
        }
    }
    profile custom-av-profile {
        notification-options {
            virus-detection {
                type message; 
                notify-mail-sender;
               
custom-message "Virus detected in your mail";
                custom-message-subject "Virus Detection Notification";
            }

        }
    }
}

However, a notification mail is not sent from the SRX device to the sender with only the configuration.

Cause:
The following notification features on AV need the configuration for the SMTP feature:
 
  • pattern update

  • virus detection

  • fallback-block

But the SMTP information is not configured, as seen in the above example.

Note: The following notification features do not require the SMTP configuration:
 
  • custom-message for virus detection.

  • custom-message for fallback-block.

  • fallback-non-block.
Solution:
To complete the configuration, the following SMTP server configuration is required:
root@srx# show smtp
    primary-server {
        address 1.2.3.4;
        login "admin@example.com" {
            password "$ABC123"; ## SECRET-DATA
        }
    }
[edit]
root@srx#
Modification History:
2020-02-26: minor non-technical edits.

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search