Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[SBR] Installing Signalware 9 SP6 on Red Hat Enterprise Linux Server

0

0

Article ID: KB27219 KB Last Updated: 04 Mar 2017Version: 2.0
Summary:
This article lists several packages which are essential for installing Signalware on Red Hat Enterprise Linux (RHEL) servers, but which may not be present initially.

Symptoms:
When installing Signalware 9 SP6 and above on Red Hat Enterprise Linux Server, ensure that the packages listed in the Solution are installed.

You may receive an error message if these packages are not present.

Cause:
 You may receive an error message if these packages are not present.

The problem comes during Commission Instances due to non-availability of "glibc-devel(32 bit)" rpm.
Solution:

Before installing Signalware 9 SP6 or later on Red Hat Enterprise Linux Serve, ensure that the following packages are installed. If they are not present, they must be installed using either RPM or YUM.

Red Hat Enterprise Linux Server Release 5 Update 3 or later
(NOTE: SBR Carrier is only supported on RHEL 6)

  • kernel-2.6.18-128.1.1.el5 or later, configured with smp enabled.

  • kernel-devel-2.6.18-128.1.1.el5 or later, matching the running smp enabled kernel

  • kernel-headers-2.6.18-128.1.1.el5 or later, matching the running smp enabled kernel

  • bash-3.1-16.1or later

  • bind-utils-9.3.3-10.el5 and bind-libs-9.3.3-10.el5 or later

  • coreutils-5.97-12.1.el5 or later

  • rpm-4.4.2.-47.el5 or later

  • gcc, libstdc++, libstdc++-devel, version 4.1.2-14.el5 or later

  •   libc, glibc-devel, version 2.5-18 or later

Red Hat Enterprise Linux AS/ES Release 4 Update 7 or later

(NOTE: SBR Carrier is only supported on RHEL 6)

  • kernel-smp-2.6.9-78.0.5.EL or later, matching the running smp kernel

Release 9 Service Pack 6 Linux Installation Manual 2-3
  • kernel-smp-devel-2.6.9-78.0.5.EL or later, matching the running smp kernel

  • bash-3.0-19.7 or later

  • bind-utils-9.2.4-30 or later

  • coreutils-5.2.1-31.8 or later

  • rpm-4.3.3 or later

  • gcc, libstdc++, libstdc++-devel, version 3.4.6-10 or later

  • glibc, glibc-devel, version 2.3.4-2.41 or later

64-bit x86_64 Red Hat Installations

On 64-bit Red Hat installations, both the 32-bit and 64-bit versions of Red Hat glibc, glibc-devel,
libstdc++, and libgcc package RPMs must be installed.

To verify that  the system has both 32- and 64 bit versions of these gcc compiler tools packages, type

rpm -q --queryformat “% -% -% -% \n” glibc glibc-devel libstdc++ libgcc

This rpm command must return a report as follows where xxx is the version number:

  • glibc-xxx-x86_64
  • glibc-xxx-i686
  • glibc-devel-xxx-x86_64
  • glibc-devel-xxx-i386
  • libstdc++-xxx-x86_64
  • libstdc++-xxx-i386
  • libgcc-xxx-x86_64
  • libgcc-xxx-i386
Only the 64-bit version of libstdc++-devel must be installed.

To verify the system has the 64-bit version of the libstdc++-devel package, type

rpm -q --queryformat “% -% -% -% \n” libstdc++-devel

This must return a report as follows where xxx is the version number:


libstdc++-devel-xxx-x86_64

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search