Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[T/M/MX] LSP not able to change to 'Up' in a multi-area LSP path

0

0

Article ID: KB27481 KB Last Updated: 26 Sep 2013Version: 1.0
Summary:

This article describes an issue in which a newly configured label switched path (LSP) does not change to the 'Up' state, due to the LSP path traversing multiple areas or autonomous systems (ASs). To allow the LSP to change to the 'Up' state in a multiple area LSP path, a router must be able to perform a route lookup in the Interior Gateway Protocol (IGP) database. To permit this, the inter-domain parameter must be configured.

Symptoms:

When configuring LSPs which will traverse multiple areas or ASs, a router may be unable to locate a path using intra-domain Constrained Shortest Path First (CSPF) lookup.

Cause:

Intra-domain CSPF route lookups using in the traffic engineering database (TED) may result in a router being unable to find a route where multiple areas or ASs comprise the path an LSP must take to reach the configured destination.

Solution:

To allow the LSP to change to the 'Up' state in a multiple area LSP path, a router must be able to perform a route lookup in the IGP database. In order to allow the router to perform an IGP lookup for a multi-area LSP, the following parameter must be configured:

inter-domain

This parameter can be configured in the following hierarchies:

[edit protocols mpls label-switched-path label-switched-path-name]
[edit logical-systems logical-system-name protocols mpls label-switched-path label-switched-path-name]

This parameter allows the router to search the IGP database and  complete the LSP path lookup. The LSP should change to the 'Up' state.

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search