Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[Junos Space] Is it possible to downgrade Junos Space?

0

0

Article ID: KB27881 KB Last Updated: 16 Mar 2018Version: 3.0
Summary:

This article provides information on whether a downgrade of the Platform is possible on the Junos Space or not. Downgrading is not possible; although two workarounds are proposed.

Symptoms:

Customers sometimes need to perform a downgrade of the Junos Space Platform.

Cause:

Sometimes, a few applications are not supported on the Junos Space Platform. In such scenarios, a downgrade is required to achieve supportability.

Solution:

Downgrade of the Junos Space Platform is not possible.

There are two options to go back to the previous version:

Option 1: (Snapshot taken before upgrade)

Virtual Machine:
VM snapshot of the Space system must be taken before the Upgrade.  This is best done in a Powered OFF state; especially if you have multiple Space nodes as ALL must be snapshoted at the same moment in time, this is not possible with the VMs in operation    See your Hypervisor  documentation on how to take and manage snapshots.

Appliance:
For the JA1500/JA2500, if a System Snapshot of the previous version was taken before going through with the upgrade, it is possible to revert back to the older version without having to re-image Junos Space. 

Option 2: (no snapshot available, restore pre-upgrade backup)

If no snapshot was taken, then the only option left is to re-image the Junos Space to the older version.  Download the platform image from the Juniper Network support site Junos Space Network Application Software Download page.

Warning: In this procedure, any changes done after the selected pre-upgrade backup will be lost.

 

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search