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[M/MX/T/TX] KRT queue incrementing with log message "Possible slowest client is slaveRE1"

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Article ID: KB28300 KB Last Updated: 09 Feb 2017Version: 3.0
Summary:

This article will explain the steps to take when the number of tasks in the KRT queue is incrementing and the error message "Possible slowest client is slaveRE1" appears in the log.

Symptoms:

Users may notice a network impact that upon investigation shows that tasks are piling up in the KRT queue. Review of the log messages reveals the following:

Sep 8 17:24:11 lab-re0 /kernel: rt_pfe_veto: Possible slowest client is slaveRE1. States processed - 405317. States to be processed - 597481433

Why are the jobs not being processed as they should, and what does this message mean?


Cause:

If users are encountering both these scenarios, they are likely encountering a day one issue, where routing protocol process daemon (RPD) work is getting stalled during large Border Gateway Protocol (BGP) convergence events.

This issue is explained in and the software fixes are located in PR836197.

As explained in the PR, this problem may happen under following conditions:

  1. Network events causing updates for multiple BGP peers (such as the result of "clear bgp neighbor", RPD restart or router reboot).

  2. The following tasks inside RPD are created, here listed from higher to lower priority (lower value means higher priority):

  3. SPF job (priority 3)
    BGP Updates job (priority 4)
    KRT job (priority 5)
  4. Shortest path first (SPF) jobs, responsible for initial policy evaluation, can "starve" either BGP Updates or KRT jobs.

Solution:

To determine if the issue is caused by this problem, collect the following information:

cli> show task jobs

In the output, check the "Misses" columns (4th column). If there are jobs with a high number of "Misses" - usually in the 10,000 or more -- it means this type of job has a low priority. This is shown in the "Pri" value - 1st column - with higher number.. Low priority jobs will not have a chance to run.

To correct this issue, upgrade the router to one of these fixed versions of Junos OS:

  • 11.4R8
  • 12.1R7
  • 12.1X44-D20
  • 12.1X45-D10
  • 12.2R5
  • 12.3R3
  • 13.1R1
  • 13.2R1

If this PR does not apply, or upgrading does not resolve the issue, then open up a case with JTAC.



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