Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[MX] Example - HELPER BOOTP configuration for virtual router to virtual router using Logical Tunnel Interfaces

0

0

Article ID: KB28784 KB Last Updated: 02 Jun 2015Version: 2.0
Summary:

This article explains how to configure bootp for virtual router (VR) to VR functionality using Logical Tunnel Interface (lt-). This is when the client facing interface is on one virtual router and the external DHCP server resides on a different virtual router. There are a couple of ways of having bootp handle this type of configuration, but this article will use lt- interfaces to accomplish this.

Symptoms:

Goal: provide a configuration example to assist customers having DHCP clients in one virtual router and access to the DHCP server is through a different virtual router. This can be accomplished using logical tunnels to route from the DHCP server RI and the Client RI.

Cause:

Solution:

The following is a configuration example showing that DHCP clients in RI Clients will be able to receive a leased IP address from a DHCP server which is located externally from a RI Server using a logical tunnel.

Topology:
Client facing Interface – ge-1/3/9.100
Server facing interface – ge-1/0/0.0

Tunnel Interface configuration:
lab@MX80-user# show chassis  
aggregated-devices {
    ethernet {
        device-count 15;
    }
}
fpc 0 {
    pic 0 {
        tunnel-services {
            bandwidth 1g;
        }
    }
lab@MX80-user# show interfaces lt-0/0/10     
unit 100 {
    encapsulation ethernet;
    peer-unit 200;
    family inet {
        address 39.39.39.2/24;
    }
}
unit 200 {
    encapsulation ethernet;
    peer-unit 100;
    family inet {
        address 39.39.39.1/24;
    }
}
	
Interface configuration:
[lab@MX80-user# run show configuration interfaces ge-1/3/9 
vlan-tagging;
unit 100 {
    description BOOTP-CLIENT;
    vlan-id 100;
    family inet {
        address 25.25.25.1/24;
    }
}
lab@MX80-user# show interfaces ge-1/0/0   
unit 0 {
    description TO-DHCP-SERVER;
    family inet {
        address 150.150.150.1/24;
    }
}

ROUTING-INSTANCE Configuration:
lab@MX80-user# show routing-instances 
CLIENT {
    instance-type virtual-router;
    interface lt-0/0/10.100;
    interface ge-1/3/9.100;
    interface lo0.100;
    routing-options {
        static {
            route 41.41.41.0/24 next-hop 39.39.39.1;
            route 150.150.150.0/24 next-hop 39.39.39.1;
        }
    }
}
SERVER {
    instance-type virtual-router;
    interface lt-0/0/10.200;
    interface ge-1/0/0.0;
    interface lo0.200;
    routing-options {
        static {
            route 40.40.40.0/24 next-hop 39.39.39.2;
            route 25.25.25.0/24 next-hop 39.39.39.2;
        }
    }
}
Routing Table for both RI:
CLIENT.inet.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

25.25.25.0/24      *[Direct/0] 02:51:16
                    > via ge-1/3/9.100
25.25.25.1/32      *[Local/0] 02:51:16
                      Local via ge-1/3/9.100
39.39.39.0/24      *[Direct/0] 00:53:40
                    > via lt-0/0/10.100
39.39.39.2/32      *[Local/0] 00:53:40
                      Local via lt-0/0/10.100
40.40.40.1/32      *[Direct/0] 3d 00:16:48
                    > via lo0.100
41.41.41.0/24      *[Static/5] 00:53:40
                    > to 39.39.39.1 via lt-0/0/10.100
150.150.150.0/24   *[Static/5] 00:49:18
                    > to 39.39.39.1 via lt-0/0/10.100
                                        
SERVER.inet.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

25.25.25.0/24      *[Static/5] 00:49:18
                    > to 39.39.39.2 via lt-0/0/10.200
39.39.39.0/24      *[Direct/0] 00:53:40
                    > via lt-0/0/10.200
39.39.39.1/32      *[Local/0] 00:53:40
                      Local via lt-0/0/10.200
40.40.40.0/24      *[Static/5] 00:53:40
                    > to 39.39.39.2 via lt-0/0/10.200
41.41.41.1/32      *[Direct/0] 3d 00:16:48
                    > via lo0.200
150.150.150.0/24   *[Direct/0] 02:50:24
                    > via ge-1/0/0.0
150.150.150.1/32   *[Local/0] 02:50:24
                      Local via ge-1/0/0.0
Helper bootp configuration:
[edit]
lab@MX80-user# show forwarding-options helpers bootp 
relay-agent-option;
interface {
    ge-1/3/9.100 {
        server 150.150.150.2 routing-instance CLIENT;
    }
}
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search