Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[EX] Unable to push AIS script to EX switches (VC) from Junos Space running Junos 11.4R1.6

0

0

Article ID: KB28889 KB Last Updated: 05 Mar 2017Version: 2.0
Summary:

This article describes why the AIS script cannot be pushed to EX switches (VC) from Junos Space running Junos 11.4R1.6.

Symptoms:

Unable to push the AIS script from Junos Space to virtual chassis using the CLI command below:

request system script add

The following error is received:

Error Package must match hardware or package is corrupted. Upgrade failed.

This error is also received when an attempt is made to add the AIS script directly on the VC.

Cause:

Solution:

The virtual chassis of the EX4200 or the EX4500 running Junos 11.4R1.6 or 11.4R2.14 is unable to push AIS scripts on all members from the master. Also, the AIS script cannot be added to virtual chassis members using Junos Space. But, the AIS script can be added to the individual members.

When the AIS script is added on an individual basis from Junos Space or VC members, Junos Space is unable to check the AIS script on the VC.

On EX4500 VC two member

{master:0}
root@JTAC-LAB-4500vc> show version
fpc0:
--------------------------------------------------------------------------
Hostname: JTAC-LAB-4500vc
Model: ex4500-40f
JUNOS Base OS boot [11.4R1.6]

fpc1:
--------------------------------------------------------------------------
Hostname: JTAC-LAB-4500vc
Model: ex4500-40f
JUNOS Base OS boot [11.4R1.6]

{master:0}
root@JTAC-LAB-4500vc> request system software add /var/tmp/jais-3.7R3.0-signed.tgz >>>> CLI Command

Retrieving software images. This process can take several minutes. Please be patient..

Package must match hardware or package is corrupted. Upgrade failed. >>>> Error

Same Error message is received on Junos Space >>>>>>>>>>>>>>

Above mentioned issue is resolved in 12.1 and later codes

root@JTAC-LAB-4500vc> show version
fpc0:
--------------------------------------------------------------------------
Hostname: JTAC-LAB-4500vc
Model: ex4500-40f
JUNOS Base OS boot [12.1R4.7]

fpc1:
--------------------------------------------------------------------------
Hostname: JTAC-LAB-4500vc
Model: ex4500-40f
JUNOS Base OS boot [12.1R4.7]

{master:0}
root@JTAC-LAB-4500vc> request system scripts add /var/tmp/jais-3.7R3.0-signed.tgz

Retrieving software images. This process can take several minutes. Please be patient..

Checking pending install on fpc1

Checking pending install on fpc0
Pushing bundle to fpc1

Validating on fpc1
[: -a: unexpected operator

Validating on fpc0
[: -a: unexpected operator
Done with validate on all virtual chassis members >>>> Successful

This issue is resolved from Junos 12.1 onward.

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search