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[SRX] Client connecting to SRX is no longer presented with ability to download and install Pulse client from the SRX

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Article ID: KB29637 KB Last Updated: 24 Dec 2016Version: 2.0
Summary:

Windows Pulse client is no longer available directly from SRX.

This article is a part of the Dynamic VPN Resolution Guide: KB17220 - Resolution Guide - SRX - Troubleshoot Pulse VPN connections to SRX.
Symptoms:

After upgrading Junos OS, browser connections to https://<srx device ip> or https://<srx device ip>/dynamic-vpn, for SRX devices configured with Dynamic-VPN,  are no longer prompted to download Pulse client.   

The following message is reported: 'The SRX no longer provides hosting of the Pulse Client for direct download.  Please obtain the Pulse Client from the Pulse Website.'



The Junos Pulse product line is now owned, operated and supported by Pulse Secure, LLC. As of July 31, 2015, all customer facing systems and services have been transitioned to Pulse Secure.

JTAC engineers supporting the Junos Pulse product line have also moved to Pulse Secure and will continue to support customers globally.

Junos Pulse products include:

Junos Pulse Secure Access Service (SA/SSL VPN)
Junos Pulse Access Control Service (IC/UAC)
Junos Pulse Desktop and Mobile
SBR Enterprise
Odyssey Access Client Enterprise Edition (OAC EE)
Mobile Security Suite (MSS)

For all support related inquiries on Pulse products, please visit http://www.pulsesecure.net/support.

Cause:

Junos OS no longer provides direct download of Pulse client via SRX as of the following Junos releases:

  • Junos 11.4R13
  • Junos 12.1X44-D45
  • Junos 12.1X46-D30
  • Junos 12.1X47-D15 and subsequent releases
Solution:

Obtain Pulse software manually and install it on the client system.

  1. Verify client requirements. See KB17436 - [SRX] Minimum requirements for client and SRX device.
  2. Download Pulse software. See Junos Pulse - Download Software.

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