Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

Example - Configuring an EX Series switch with Cisco Q-in-Q tunneling

0

0

Article ID: KB29846 KB Last Updated: 04 Mar 2017Version: 2.0
Summary:

This article describes how to configure an EX Series switch with Cisco Q-in-Q tunneling.

Symptoms:

802.1Q (dot1Q) tunneling (Q-in-Q) is commonly used by service providers on metro Ethernet access networks. The protocol extensions are defined in IEEE 802.1ad. A "service" dot1Q tag is used on the service provider network to segregate traffic into different VLANs defined by the service provider. The original "customer" dot1q tag of the packet is transmitted transparently.

Setup/Topology:

    SW1                         SW2                          SW3                   SW4
[EX1]Ge-0/0/0--------Ge-0/0/23[EX2]Ge-0/0/14+++++++Gi0/2[Cisco]Gi0/1 -------ge-0/1/0[EX4]
 vlan100                    vlan200                      vlan200               vlan 100

Because this type of configuration is not available to customers, they raise critical issues to ATAC which ends up as a config issue.

Cause:
 
Solution:

Configuration:

SW1:

set interfaces ge-0/0/0 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members 100
set vlans vlan100 vlan-id 100
set vlans vlan100 l3-interface vlan.100
set interfaces vlan unit 100 family inet address 20.0.0.1/24


SW2:

set interfaces ge-0/0/14 mtu 9216
set interfaces ge-0/0/14 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/14 unit 0 family ethernet-switching vlan members 200
set ethernet-switching-options analyzer dot1q-tunnel input ingress interface ge-0/0/14.0
set ethernet-switching-options analyzer dot1q-tunnel input egress interface ge-0/0/14.0
set vlans v200 interface ge-0/0/14.0
set interfaces ge-0/0/14 mtu 9216
set ethernet-switching-options dot1q-tunneling ether-type 0x8100
set vlans v200 vlan-id 200
set vlans v200 interface ge-0/0/23.0
set vlans v200 interface ge-0/0/14.0
set vlans v200 dot1q-tunneling customer-vlans 100-200

SW3 Cisco:

interface GigabitEthernet0/1
switchport access vlan 200
switchport mode dot1q-tunnel
load-interval 60
l2protocol-tunnel stp
no cdp enable
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
load-interval 30

SW4:

set interfaces ge-0/1/0 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/1/0 unit 0 family ethernet-switching vlan members 100
set vlans v100 vlan-id 100
set vlans v100 l3-interface vlan.100
set interfaces vlan unit 100 family inet address 20.0.0.2/24

Note: On the port between SW2 and SW3[Cisco], set the MTU to the MAX, this is to avoid packet drops exceeding the MTU due to Q-in-Q tagging.

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search