Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[SRX] Example - Configuring DHCPv6 NA over PPPoE

0

0

Article ID: KB30956 KB Last Updated: 04 Mar 2017Version: 2.0
Summary:

This article provides an example on how to configure DHCPv6 NA over PPPoE.

Symptoms:

To provide a configuration suite using SRX devices for a DHCPv6 topology as described below:

Topology



Cause:

Solution:

The configuration below have been confirmed using Junos 12.1X46-D50.

Configurations:

        SRX1 DHCPv6 Server
  • DHCPv6 server configuration
set system services dhcp-local-server dhcpv6 overrides interface-client-limit 100
set system services dhcp-local-server dhcpv6 group my-group overrides interface-client-limit 200
set system services dhcp-local-server dhcpv6 group my-group overrides delegated-pool v6-na-pool
set system services dhcp-local-server dhcpv6 group my-group interface pp0.0

  •  PPPoE Configuration
set interfaces ge-0/0/5 unit 0 encapsulation ppp-over-ether
set interfaces pp0 unit 0 ppp-options chap access-profile prof-ge001
set interfaces pp0 unit 0 pppoe-options underlying-interface ge-0/0/5.0
set interfaces pp0 unit 0 pppoe-options server
set interfaces pp0 unit 0 family inet6 address 3000::1/64

  • Router advertisement configuration
set protocols router-advertisement interface pp0.0 max-advertisement-interval 20
set protocols router-advertisement interface pp0.0 min-advertisement-interval 10
set protocols router-advertisement interface pp0.0 managed-configuration
set protocols router-advertisement interface pp0.0 other-stateful-configuration
set protocols router-advertisement interface pp0.0 prefix 3000::/64

  • Enable IPv6 (Chassis reboot is required)
set security forwarding-options family inet6 mode flow-based 

  • PPPoE profile configuration
set access profile prof-ge001 client test_user chap-secret test

  • NA address pool configuration
set access address-assignment pool v6-na-pool family inet6 prefix 3000::/64
set access address-assignment pool v6-na-pool family inet6 range v6-range low 3000::2/128
set access address-assignment pool v6-na-pool family inet6 range v6-range high 3000::10/128


        SRX2 DHCPv6 Client (NA)
  • PPPoE configuration
set interfaces ge-0/0/0 unit 0 encapsulation ppp-over-ether
set interfaces pp0 unit 0 ppp-options chap default-chap-secret test
set interfaces pp0 unit 0 ppp-options chap local-name test_user
set interfaces pp0 unit 0 ppp-options chap passive
set interfaces pp0 unit 0 pppoe-options underlying-interface ge-0/0/0.0
set interfaces pp0 unit 0 pppoe-options auto-reconnect 5
set interfaces pp0 unit 0 pppoe-options client

  • DHCPv6 client configuration
set interfaces pp0 unit 0 family inet negotiate-address
set interfaces pp0 unit 0 family inet6 dhcpv6-client client-type statefull
set interfaces pp0 unit 0 family inet6 dhcpv6-client client-ia-type ia-na
set interfaces pp0 unit 0 family inet6 dhcpv6-client client-identifier duid-type duid-ll

  • Router advertisement configuration
This is to receive router advertisement from the server to create default route automatically.

set protocols router-advertisement interface pp0.0

  • Enable ipv6(Chassis reboot is required)
set security forwarding-options family inet6 mode flow-based

Note: On DHCPv6 Server SRX, for Router advertisement configuration, "prefix 3000::/64" is configured in this article.
If "equal or less than /48 prefix" is preferred, see PR1161394 (addressed from 12.1X46-D50, 12.1X47-D40, 12.3X48-D30).

Verification:

         SRX1 DHCPv6 server

     root@SRX1-DHCPv6-Server> show dhcpv6 server binding detail

     Session Id: 3
             Client IPv6 Address: 3000::2/128
             Client DUID: LL0x1-28:8a:1c:43:08:40
             State: BOUND(DHCPV6_LOCAL_SERVER_STATE_BOUND)
             Lease Expires: 2016-06-03 09:01:34 UTC
             Lease Expires in: 83607 seconds
             Lease Start: 2016-06-02 09:01:34 UTC
             Last Packet Received: 2016-06-02 09:01:35 UTC
             Incoming Client Interface: pp0.0
             Server Ip Address: 0.0.0.0
             Client Pool Name: v6-na-pool
             Client Prefix Pool Name: v6-na-pool
             Client Id Length: 10
             Client Id: /0x00030001/0x288a1c43/0x0840

      root@SRX1-DHCPv6-Server> show ipv6 router-advertisement
      Interface: pp0.0
           Advertisements sent: 336, last sent 00:00:00 ago
           Solicits received: 0
           Advertisements received: 15
           Advertisement from fe80::2a8a:1c0f:fc43:fe40, heard 00:00:31 ago
                Managed: 0 [1]
                Other configuration: 0 [1]
                Reachable time: 0 ms
                Default lifetime: 1800 sec [60 sec]
                Retransmit timer: 0 ms
                Current hop limit: 64


           SRX2 DHCPv6 client (NA)

      root@SRX2-DHCPv6-Client_NA> show dhcpv6 client binding detail

         Client Interface: pp0.0
              Hardware Address: 28:8a:1c:43:fe:40
              State: BOUND(DHCPV6_CLIENT_STATE_BOUND)
              ClientType: STATEFUL
              Lease Expires: 2016-06-03 08:43:28 UTC
              Lease Expires in: 83590 seconds
              Lease Start: 2016-06-02 08:43:28 UTC
              Bind Type: IA_NA
              Client DUID: LL0x29-28:8a:1c:43:fe:40
              Rapid Commit: Off
              Server Ip Address: fe80::2a8a:1c0f:fc49:b17c
              Client IP Address: 3000::2/128

         DHCP options:
             Name: server-identifier, Value: VENDOR0x00000583-0x42563431

         root@SRX2-DHCPv6-Client_NA> show route table inet6

         inet6.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
         + = Active Route, - = Last Active, * = Both

              ::/0 *[Access-internal/12] 00:51:20
                   > to fe80::2a8a:1c0f:fc49:b17c via pp0.0

              3000::/64 *[Access-internal/12] 00:51:20
                        > to fe80::2a8a:1c0f:fc49:b17c via pp0.0
              3000::2/128 *[Local/0] 00:51:25
                           Local via pp0.0
              fe80::2a8a:1c0f:fc43:fe40/128
                           *[Local/0] 17:08:11
                           Local via pp0.0

         root@SRX2-DHCPv6-Client_NA> show ipv6 router-advertisement
         Interface: pp0.0
              Advertisements sent: 16, last sent 00:00:25 ago
              Solicits received: 0
              Advertisements received: 349
              Advertisement from fe80::2a8a:1c0f:fc49:b17c, heard 00:00:17 ago
                   Managed: 1 [0]
                   Other configuration: 1 [0]
                   Reachable time: 0 ms
                   Default lifetime: 60 sec [1800 sec]
                   Retransmit timer: 0 ms
                   Current hop limit: 64
                   Prefix: 3000::/64
                        Valid lifetime: 2592000 sec
                        Preferred lifetime: 604800 sec
                        On link: 1
                        Autonomous: 1


Note: For DHCPv6 PD over PPPoE, refer to KB30824 - [SRX] Example - Configuring DHCPv6 PD over PPPoE

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search