Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[SRX] log file debug_wmid appears after upgrading to Junos 12.1X47

0

0

Article ID: KB31069 KB Last Updated: 04 Feb 2020Version: 2.0
Summary:

This article discusses the new log file debug_wmid in the SRX file system after upgrading to Junos 12.1X47. This behavior is by design.

Symptoms:

There are some new logs named debug_wmid in the file system after upgrading to Junos 12.1 X47.

root@SRX> start shell user root
root@SRX% ls -al /cf/var/log
/cf/var/log:
total 45912
....
-rw-r--r-- 1 root wheel 10240571 Jul 17 19:59 debug_wmid.1
-rw-r--r-- 1 root wheel 7256371 Jul 26 12:45 debug_wmid.2

...
Cause:

This is a new feature added in Junos 12.1X47. The debug_wmid is a debug file for the userFW feature introduced in 12.1X47. The wmic process, which is a process for userFW, generates and stores messages in the debug_wmid file.

This file is created when the wmic process is started.

Example:
  • Device reboot
  • wmic process restart (this may not happen if you do this manually)
Solution:

This behavior is by design. You can delete the file, but it will regenerate after a reboot.

Examples:
  • Kill the wmic process from the Unix shell. It will automatically spawn with a different PID and the files continue to update.
  • Delete the debug_wmid.1 and debug_wmid.2 files. They will not regenerate until the system is rebooted.
Modification History:

2020-02-04: Added that this behavior is by design.

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search