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Junos Space Platform 15.2R1 does not allow the installation of Service Now/Service Insight 16.1R1 or 16.2R1

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Article ID: KB31098 KB Last Updated: 11 Jan 2017Version: 4.0
Summary:
Junos Space Platform 15.2R1 will not allow the installation of Service Now/Service Insight 16.1R1.

Symptoms:
When attempting to upgrade to or freshly install Service Now/Service Insight 16.1R1 or 16.2R1, Junos Space Network Management Platform version 15.2R1 rejects the install.

Cause:
The upgrade or install fails because Junos Space Network Management Platform has a mechanism to stop non-compatible versions of apps from installing.
This compatibility list has not been updated in Junos Space Network Management Platform 15.2R1 to allow the latest releases of Service Now/Service Insight.
All versions of Service Now/Service Insight 16.1R1 and later could face this issue.

Junos Space Network Management Platform 15.1Rx and 15.2R2 do not have this issue.
Solution:
There are two workaround to allow Service Now/Service Insignt 16.1R1 or 16.2R1 to install properly.
Before applying one of the workarounds, be sure to check compatibility by reviewing the Service Now/Service Insight release notes.

Workaround 1:
  1. Login to the Junos Space CLI as admin.
  2. Enter debug mode from the menu to access the CLI
  3. Edit the file using a linux text editor: /var/cache/jboss/jmp/appVersionListFile.txt
  4. Add "16.1" and "16.2" to the lines in the file that begin with "aim" and "si"
Example of completed edit:
[root@space-0003003030 ~]# cat /var/cache/jboss/jmp/appVersionListFile.txt
aim=13.3,14.1,15.1,
16.1
ServiceProvisioning=12.3,13.1
sm=15.1
QoSArchitectApp=12.3,13.1
jive=12.2
si=13.3,14.1,15.1,16.1
fm=12.2
slb=12.2
TransportActivate=12.3,13.1
OAM=12.3,13.1
Timing=12.3,13.1
cm=2.0
ecm=15.1
seci=15.1
[root@space-0003003030 ~]#

If a previous version of Service Now/Service Insight is already installed, the same changes as mentioned above are required to upgrade to Service Now/Service Insight 16.1R1 and 16.2R1.


Workaround 2:

If Junos Space Platform has not been upgraded from 15.1Rx to 15.2R1 then a second option is to upgrade Service Now/Service Insight first to 16.1R1 or 16.2R1 and then upgrade Space Platform. (SN/SI 16.1 and 16.2 is supported on all 15.1x platforms).
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