Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

Syslog message: XMCHIP.*DRD.*Fabric parcel timeout error

0

0

Article ID: KB31617 KB Last Updated: 06 Oct 2021Version: 4.0
Summary:

The "Fabric parcel timeout error" message reports a software or transient hardware condition.


This is a Troubleshooting Article for a PFE ASIC Syslog Event.
To view other documented syslog events related to XMCHIP, XLCHIP, MQCHIP, LUCHIP, EACHIP, and PECHIP, see KB31893 - Index of Articles for Troubleshooting PFE ASIC Syslog Events.

.
Symptoms:

When a "Fabric parcel timeout error" event occurs, a message similar to the following is reported:

Dec 19 16:08:56 router0 lcc4-fpc1 XMCHIP(1): DRD1: Fabric parcel timeout error - Valid 1, Reorder ID 273, PT table index 3457

Indications:
  • Single occurrence may lead to full/partial wedge (packet forwarding impact) condition and other events being reported.
  • Alarm will be raised in the case where packet forwarding has permanent impact.
  • Persistent service impact until FPC is reset with the event script: KB31867 - Generic pfe-disable event script

 

Cause:

The XMCHIP may receive corrupted parcels from the fabric (DRD1), which in turn can result in DRD parcel timeout errors. Corrupted parcels from the Lookup chip LU/XL to Center Chip (XM) can also compromise packet forwarding and report DRD parcel timeout errors. An additional parcel verification check has been added internally to prevent sending corrupted parcels to the center chip (XM).

The following KB entries might be relevant:
KB31602 - Syslog message: XMCHIP.*DRD.*Command sequence error
KB31701 - Syslog message: XMCHIP.*DRD.*Wan parcel timeout error
 

 

Solution:



Perform these steps to determine the cause and resolve the problem (if any).  Continue through each step until the problem is resolved.

  1. Collect the show command output.

    Capture the output to a file (in case you have to open a technical support case). To do this, configure each SSH client/terminal emulator to log your session.

    show log messages
    show log chassisd
    start shell network pfe <fpc#>
    show nvram
    show syslog messages
    exit


  2. Analyze the show command output.

    In the 'show log messages', review the events that occurred at or just before the appearance of the "Fabric parcel timeout error" message. Frequently these events help identify the cause.

    1. No RMA required.
    2. JunOS enhancement with 15.1F6-S8, 16.1R7, 17.1R3, 17.2R2, 17.3R1 and 17.4 or higher, has been done to automatic recovery such events.
    3. FPC restart should clear this error in most conditions.
    4. Run the generic pfe-disable event script KB31867 - Generic pfe-disable event script which will detect the wedge condition that happens as a result of this event and invoke the pfe-disable action. An FPC restart at a later time during a maintenance window is needed to bring the PFE back into service.
    5. Contact your technical support representative if the issue is seen after the FPC restart.​​
​​

This article is indexed in KB31893 - Primary Index of Articles for Troubleshooting PFE ASIC Syslog Events; tag XMCHIPTSG


Tip: When looking at an event in the logs, it is important to focus on the first error message in a collection of syslog messages. The first error message is usually the cause of all the follow-on error messages. The follow-on collateral damage error messages can be ignored.

 

Modification History:
2019-10-14: JunOS Enhancements which does automatic recover from such error condition

Related Links

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search