Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

Syslog message: XMCHIP.*MALLOC.*DREF memory parity error

0

0

Article ID: KB31696 KB Last Updated: 06 Oct 2021Version: 3.0
Summary:

The "DREF memory parity error" message reports a transient hardware issue.


This is a Troubleshooting Article for a PFE ASIC Syslog Event.
To view other documented syslog events related to XMCHIP, XLCHIP, MQCHIP, LUCHIP, EACHIP, and PECHIP, see KB31893 - Index of Articles for Troubleshooting PFE ASIC Syslog Events.

.
Symptoms:

When a "DREF memory parity error" event occurs, a message similar to the following is reported:
Jan 28 11:05:42 router0 : %PFE-3: fpc2 XMCHIP(1): XMCHIP(1): MALLOC: DREF memory parity error

Indications:

  1. Single occurrence of syslog, not seen with other events, indicates a one time hardware error. Multiple continuous occurrences indicate persistent underlying issues.

  2. Traffic impact or PFE wedge may happen if errors are seen repeatedly.

 

Cause:

The cause is due to a parity error in one of the XMCHIP's MALLOC blocks.

 

Solution:



Perform these steps to determine the cause and resolve the problem (if any).  Continue through each step until the problem is resolved.

  1. Collect the show command output.

    Capture the output to a file (in case you have to open a technical support case). To do this, configure each SSH client/terminal emulator to log your session.

    show log messages
    show log chassisd
    start shell network pfe <fpc#>
    show nvram
    show syslog messages
    exit

  2. Analyze the show command output.

    In the 'show log messages', review the events that occurred at or just before the appearance of the "DREF memory parity error" message. Frequently these events help identify the cause.
    No RMA required.

  3. During a maintenance window, as it will impact transit traffic, try the following:

    • Reset the specific hardware reporting the error. 

      To ‘reset an FPC’, for example on an MX480:
      Run the CLI command ‘request chassis fpc slot # offline’,
      Wait 30 seconds.
      Then follow with the CLI command ‘request chassis fpc slot # online’.
      For more information on the command see:  request chassis fpc.

    • Swap the FPC with a spare, or switch to a redundant FPC.
  4. If the log messages continue, open a case with your technical support representative to investigate the issue further.

This article is indexed in KB31893 - primary Index of Articles for Troubleshooting PFE ASIC Syslog Events; Tag XMCHIPTSG.

Tip: When looking at an event in the logs, it is important to focus on the first error message in a collection of syslog messages. The first error message is usually the cause of all the follow-on error messages. The follow-on collateral damage error messages can be ignored.

 

Modification History:
2019-10-14: Article reviewed for accuracy; no changes required.
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search