[SRX] Example Configuration - LACP on Layer 2 transparent mode Chassis Cluster

  [KB31771] Show Article Properties


Summary:

This article explains how to configure LACP on layer 2 transparent mode Chassis Cluster on SRX Branch Devices.

LACP support for SRX300, SRX320, SRX340, SRX345, SRX1500, SRX4100, SRX4200, SRX5400, SRX5600, and SRX5800 devices and vSRX instances. Starting with Junos OS release
15.1X49-D80, LACP is supported in Layer 2 transparent mode in addition to the existing support in Layer 3 mode.< /p>

For more information, refer to Release 15.1X49-D80 Software Features
 

Solution:
​Topology:

LACP ae1:
SRX (ge-0/0/3) is connected to EX (ge-0/0/0)
SRX (ge-0/0/4) is connected to EX (ge-0/0/2)

LACP ae2:
SRX (ge-5/0/3) is connected to EX (ge-0/0/1)
SRX (ge-5/0/4) is connected to EX (ge-0/0/3)

Configuration Example:

set chassis aggregated-devices ethernet device-count 10
set interfaces ge-0/0/0 ether-options 802.3ad ae1
set interfaces ge-0/0/1 ether-options 802.3ad ae2
set interfaces ge-0/0/2 ether-options 802.3ad ae1
set interfaces ge-0/0/3 ether-options 802.3ad ae2
set interfaces ae1 aggregated-ether-options lacp active
set interfaces ae1 aggregated-ether-options lacp periodic slow
set interfaces ae1 unit 0 family ethernet-switching port-mode trunk
set interfaces ae1 unit 0 family ethernet-switching vlan members vlan10
set interfaces ae1 unit 0 family ethernet-switching vlan members vlan40
set interfaces ae2 aggregated-ether-options lacp active
set interfaces ae2 aggregated-ether-options lacp periodic slow
set interfaces ae2 unit 0 family ethernet-switching port-mode trunk
set interfaces ae2 unit 0 family ethernet-switching vlan members vlan10
set interfaces ae2 unit 0 family ethernet-switching vlan members vlan40
set vlans vlan10 vlan-id 10
set vlans vlan40 vlan-id 40

SRX Chassis Cluster:

set interfaces ge-0/0/3 gigether-options redundant-parent reth0
set interfaces ge-0/0/4 gigether-options redundant-parent reth0
set interfaces ge-5/0/3 gigether-options redundant-parent reth0
set interfaces ge-5/0/4 gigether-options redundant-parent reth0
set interfaces irb unit 10 family inet address 192.168.1.254/24
set interfaces reth0 vlan-tagging
set interfaces reth0 redundant-ether-options redundancy-group 1
set interfaces reth0 redundant-ether-options lacp active
set interfaces reth0 redundant-ether-options lacp periodic slow
set interfaces reth0 unit 0 family ethernet-switching interface-mode trunk
set interfaces reth0 unit 0 family ethernet-switching vlan members vlan10
set interfaces reth0 unit 0 family ethernet-switching vlan members vlan40
set protocols l2-learning global-mode transparent-bridge
set vlans vlan10 vlan-id 10
set vlans vlan10 l3-interface irb.10
set vlans vlan40 vlan-id 40

{primary:node0}[edit]
root@SRX345# run show lacp interfaces 
Aggregated interface: reth0
    LACP state:       Role   Exp   Def  Dist  Col  Syn  Aggr  Timeout  Activity
      ge-0/0/3       Actor    No    No   Yes  Yes  Yes   Yes     Slow    Active
      ge-0/0/3     Partner    No    No   Yes  Yes  Yes   Yes     Slow    Active
      ge-0/0/4       Actor    No    No   Yes  Yes  Yes   Yes     Slow    Active
      ge-0/0/4     Partner    No    No   Yes  Yes  Yes   Yes     Slow    Active
      ge-5/0/3       Actor    No    No   Yes  Yes  Yes   Yes     Slow    Active
      ge-5/0/3     Partner    No    No   Yes  Yes  Yes   Yes     Slow    Active
      ge-5/0/4       Actor    No    No   Yes  Yes  Yes   Yes     Slow    Active
      ge-5/0/4     Partner    No    No   Yes  Yes  Yes   Yes     Slow    Active
    LACP protocol:        Receive State  Transmit State          Mux State 
      ge-0/0/3                  Current   Slow periodic Collecting distributing
      ge-0/0/4                  Current   Slow periodic Collecting distributing
      ge-5/0/3                  Current   Slow periodic Collecting distributing
      ge-5/0/4                  Current   Slow periodic Collecting distributing
Related Links: