Support Support Downloads Knowledge Base Juniper Support Portal Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

Syslog message: PRECL.*XM_engine.*instmem parity error detected

1

0

Article ID: KB32106 KB Last Updated: 06 Oct 2021Version: 3.0
Summary:

The "PRECL instmem parity error detected" message reports memory parity error in the XMCHIP preclassifier.

This is a Troubleshooting Article for a PFE ASIC Syslog Event.
To view other documented syslog events related to XMCHIP, XLCHIP, MQCHIP, LUCHIP, EACHIP, and PECHIP, see KB31893 - Index of Articles for Troubleshooting PFE ASIC Syslog Events.

.

Symptoms:

When a "Parity error within Preclassifier Engine" event occurs,the following error messages can be reported:

Mar 13 13:41:21.937 router-0: %PFE-6: fpc10 Error (0x340001), module: PRECL, type: instmem parity error
Mar 13 13:41:22.034 router-0: %PFE-3: fpc10 Cmerror Op Set: PRECL: XM_engine.10.2.65568 instmem parity error detected


Only Junos OS 17.2R1 17.3R1 or higher with PR1059137 â€‹will report such syslog events. 
Other symptoms are sudden high rate of DA rejects interface counters increasing. See more in Release Note of PR1059137

user@Device> show interfaces xe-9/0/0 extensive | match rej
Apr 11 15:37:45
    Input packet rejects               4087492
    Input DA rejects                   4087492    
    Input SA rejects                         0


 Indications:

  • permanent operational impact of some interfaces connected to this XM Engine of about 30% of traffic
  • Alarm will be raised

 
Cause:

This is caused due to parity memory hardware error on the XMCHIP preclassifier. This syslog event will be reported with Junos 17.2 or higher and is tracked in PR1059137. 

Solution:



Junos OS 17.3R2 or higher got enhanced to automatically recovery from such parity error condition.

Perform these steps to determine the cause and resolve the problem (if any).  Continue through each step until the problem is resolved.

  1. Collect the show command output.

    Capture the output to a file (in case you have to open a technical support case). To do this, configure each SSH client/terminal emulator to log your session.

    show log messages
    show log chassisd
    start shell network pfe <fpc#>
    show nvram
    show syslog messages
    exit

  2. Analyze the show command output.

    In the 'show log messages', review the events that occurred at or just before the appearance of the "PRECL instmem parity error detected" message. Frequently these events help identify the cause.

  • No RMA required
  • Restart the MPC and monitor the errors
  • Contact your technical support representative if the issue is seen after FPC restart.
  • The generic pfe-disable event script will invoke the pfe-disable action automatically”.  KB31867 - Generic pfe-disable event script
  • FPC restart during a maintenance window should clear this error

This article is indexed in KB31893 - Primary Index of Articles for Troubleshooting PFE ASIC Syslog Events; tag XMCHIPTSG


Tip: When looking at an event in the logs, it is important to focus on the first error message in a collection of syslog messages. The first error message is usually the cause of all the follow-on error messages. The follow-on collateral damage error messages can be ignored.

 

Modification History:

Note: KB Team - All changes to this article must be approved by the AI-Scripts Review team (pvs-scripts-review@juniper.net) before re-publishing.


AI-Scripts history:       (Updated by AI-Scripts team only)
 
Date KB Article Version AI-Scripts PR (optional) Notes
9/19/2017 1.0 1308012 New Syslog KB
       

 
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search