Support Support Downloads Knowledge Base Service Request Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[SRX] J-web shows reth interface's IP address is marked as 'configured' but cannot be recognized correctly

0

0

Article ID: KB32404 KB Last Updated: 15 Jan 2018Version: 1.0
Summary:

After configuring HA on SRX and checking the interface status via J-web, reth3 is marked as 'configured', but cannot be recognized correctly.

This article explains why changing reth-count from 3 to 4 resolves this issue.
 

Symptoms:

HA is configured as follows:

{primary:node0}[edit]

root@SRX-220-1# run show configuration |display set|no-more
set version 12.1X46-D67
set groups node0 system host-name SRX-220-1
set groups node0 interfaces fxp0 unit 0 family inet address 192.168.10.1/24
set groups node1 system host-name SRX-220-2
set groups node1 interfaces fxp0 unit 0 family inet address 192.168.10.2/24
set apply-groups "$ "
......
set chassis cluster reth-count 3
set chassis cluster redundancy-group 0 node 0 priority 100
set chassis cluster redundancy-group 0 node 1 priority 1
set chassis cluster redundancy-group 1 node 0 priority 100
set chassis cluster redundancy-group 1 node 1 priority 1
set chassis cluster redundancy-group 1 interface-monitor ge-0/0/0 weight 255
set chassis cluster redundancy-group 1 interface-monitor ge-0/0/1 weight 255
set chassis cluster redundancy-group 1 interface-monitor ge-3/0/0 weight 255
set chassis cluster redundancy-group 1 interface-monitor ge-3/0/1 weight 255
set interfaces ge-0/0/0 gigether-options redundant-parent reth0
set interfaces ge-0/0/1 gigether-options redundant-parent reth1
set interfaces ge-0/0/2 gigether-options redundant-parent reth2
set interfaces ge-0/0/4 gigether-options redundant-parent reth3
set interfaces ge-3/0/0 gigether-options redundant-parent reth0
set interfaces ge-3/0/1 gigether-options redundant-parent reth1
set interfaces ge-3/0/2 gigether-options redundant-parent reth2
set interfaces ge-3/0/4 gigether-options redundant-parent reth3
set interfaces fab0 fabric-options member-interfaces ge-0/0/5
set interfaces fab1 fabric-options member-interfaces ge-3/0/5
set interfaces reth0 redundant-ether-options redundancy-group 1
set interfaces reth0 unit 0 family inet address 192.168.0.1/24
set interfaces reth1 redundant-ether-options redundancy-group 1
set interfaces reth1 unit 0 family inet address 192.168.1.1/24
set interfaces reth2 redundant-ether-options redundancy-group 1
set interfaces reth2 unit 0 family inet address 192.168.20.1/24
set interfaces reth3 redundant-ether-options redundancy-group 1
set interfaces reth3 unit 0 family inet address 10.75.252.20/24
set routing-options static route 0.0.0.0/0 next-hop 10.75.252.251
......
set security zones security-zone test interfaces reth0.0
set security zones security-zone test interfaces reth1.0
set security zones security-zone test interfaces reth2.0
set security zones security-zone test interfaces reth3.0

{primary:node0}[edit]
root@SRX-220-1# run show interfaces terse |no-more
Interface               Admin Link Proto    Local                 Remote
ge-0/0/0                up    up  
ge-0/0/0.0              up    up   aenet    --> reth0.0
gr-0/0/0                up    up  
ip-0/0/0                up    up  
ge-0/0/1                up    up  
ge-0/0/1.0              up    up   aenet    --> reth1.0
ge-0/0/2                up    up  
ge-0/0/2.0              up    up   aenet    --> reth2.0
ge-0/0/3                up    down
ge-0/0/4                up    up  
ge-0/0/4.0              up    up   aenet    --> reth3.0
ge-0/0/5                up    up  
ge-0/0/5.0              up    up   aenet    --> fab0.0
ge-0/0/6                up    up  
ge-0/0/7                up    up  
ge-3/0/0                up    up  
ge-3/0/0.0              up    up   aenet    --> reth0.0
ge-3/0/1                up    up  
ge-3/0/1.0              up    up   aenet    --> reth1.0
ge-3/0/2                up    up  
ge-3/0/2.0              up    up   aenet    --> reth2.0
ge-3/0/3                up    down
ge-3/0/4                up    up  
ge-3/0/4.0              up    up   aenet    --> reth3.0
ge-3/0/5                up    up  
ge-3/0/5.0              up    up   aenet    --> fab1.0
ge-3/0/6                up    down
ge-3/0/7                up    up  
......
reth0                   up    up  
reth0.0                 up    up   inet     192.168.0.1/24  
reth1                   up    up  
reth1.0                 up    up   inet     192.168.1.1/24  
reth2                   up    up  
reth2.0                 up    up   inet     192.168.20.1/24 --> There is no interface reth3.
......


Cause:

The object of 'Configured' is caused by configuration mismatch, 'set chassis cluster reth-count 3'. The count is 3 but there are 4 reth interfaces. Due to “reth-count 3”, the last interface which is reth3 is not working.

There is no route even when the following is configured:

set routing-options static route 0.0.0.0/0 next-hop 10.75.252.251
set interfaces reth3 redundant-ether-options redundancy-group 1
set interfaces reth3 unit 0 family inet address 10.75.252.20/24
set routing-options static route 0.0.0.0/0 next-hop 10.75.252.251

{primary:node0}[edit]
root@SRX-220-1# run show route
 
inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
 
192.168.0.0/24     *[Direct/0] 00:49:08
                    > via reth0.0
192.168.0.1/32     *[Local/0] 00:49:08
                      Local via reth0.0
192.168.1.0/24     *[Direct/0] 00:54:33
                    > via reth1.0
192.168.1.1/32     *[Local/0] 00:58:09
                      Local via reth1.0
192.168.10.0/24    *[Direct/0] 00:58:09
                    > via fxp0.0
192.168.10.1/32    *[Local/0] 00:58:09
                      Local via fxp0.0
192.168.20.0/24    *[Direct/0] 00:54:33
                    > via reth2.0
192.168.20.1/32    *[Local/0] 00:58:09
                      Local via reth2.0

{primary:node0}[edit]
root@SRX-220-1# run ping 8.8.8.8         
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: No route to host
ping: sendto: No route to host
ping: sendto: No route to host
^C
--- 8.8.8.8 ping statistics ---
4 packets transmitted, 0 packets received, 100% packet loss

 
Solution:

Change reth-count from 3 to 4 could resolve this issue.

root@SRX-220-1# delete chassis cluster reth-count 3
root@SRX-220-1# set chassis cluster reth-count 4
root@SRX-220-1# commit

{primary:node0}[edit]
root@SRX-220-1# run show interfaces terse |no-more             
Interface               Admin Link Proto    Local                 Remote
ge-0/0/0                up    up 
ge-0/0/0.0              up    up   aenet    --> reth0.0
gr-0/0/0                up    up 
ip-0/0/0                up    up 
ge-0/0/1                up    up 
ge-0/0/1.0              up    up   aenet    --> reth1.0
ge-0/0/2                up    up 
ge-0/0/2.0              up    up   aenet    --> reth2.0
ge-0/0/3                up    down
ge-0/0/4                up    up 
ge-0/0/4.0              up    up   aenet    --> reth3.0
ge-0/0/5                up    up 
ge-0/0/5.0              up    up   aenet    --> fab0.0
ge-0/0/6                up    up 
ge-0/0/7                up    up 
ge-3/0/0                up    up 
ge-3/0/0.0              up    up   aenet    --> reth0.0
ge-3/0/1                up    up 
ge-3/0/1.0              up    up   aenet    --> reth1.0
ge-3/0/2                up    up 
ge-3/0/2.0              up    up   aenet    --> reth2.0
ge-3/0/3                up    down
ge-3/0/4                up    up 
ge-3/0/4.0              up    up   aenet    --> reth3.0
ge-3/0/5                up    up 
ge-3/0/5.0              up    up   aenet    --> fab1.0
ge-3/0/6                up    down
ge-3/0/7                up    up 
......
reth0                   up    up 
reth0.0                 up    up   inet     192.168.0.1/24 
reth1                   up    up 
reth1.0                 up    up   inet     192.168.1.1/24 
reth2                   up    up 
reth2.0                 up    up   inet     192.168.20.1/24
reth3                   up    up  
reth3.0                 up    up   inet     10.75.252.20/24 
......
 
{primary:node0}[edit]
root@SRX-220-1# run show route
 
inet.0: 11 destinations, 11 routes (11 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both
 
0.0.0.0/0          *[Static/5] 00:00:07
                    > to 10.75.252.251 via reth3.0
10.75.252.0/24     *[Direct/0] 00:00:07
                    > via reth3.0
10.75.252.20/32    *[Local/0] 00:00:07
                      Local via reth3.0
192.168.0.0/24     *[Direct/0] 00:55:33
                    > via reth0.0
192.168.0.1/32     *[Local/0] 00:55:33
                      Local via reth0.0
192.168.1.0/24     *[Direct/0] 01:00:58
                    > via reth1.0
192.168.1.1/32     *[Local/0] 01:04:34
                      Local via reth1.0
192.168.10.0/24    *[Direct/0] 01:04:34
                    > via fxp0.0
192.168.10.1/32    *[Local/0] 01:04:34
                      Local via fxp0.0
192.168.20.0/24    *[Direct/0] 01:00:58
                    > via reth2.0      
192.168.20.1/32    *[Local/0] 01:04:34
                      Local via reth2.0
 
{primary:node0}[edit]
root@SRX-220-1# run ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: icmp_seq=0 ttl=39 time=75.822 ms
64 bytes from 8.8.8.8: icmp_seq=1 ttl=39 time=77.098 ms
^C
--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 74.599/75.840/77.098/1.020 ms
Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Security Alerts and Vulnerabilities

Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search