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[Junos Space] Security Director login page shows 'Service Temporarily Unavailable'

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Article ID: KB33025 KB Last Updated: 05 Feb 2019Version: 2.0
Summary:

This article explains how to troubleshoot when the Security Director login page shows 'Service Temporarily Unavailable' even though you can login to Junos Space Network Application Platform 

Symptoms:

User is able to login to Junos Space platform page, https://<space_ip>/mainui, but Security Director login UI/GUI shows the message below:



 
Cause:

Required services are not running due to below issues.

  1. Incorrect permissions
  2. Disk space usage
     
Solution:
 
  1. Login to Junos Space CLI using admin.
  2. Check the below services status
    # /etc/init.d/slipstream status
    # /etc/init.d/redis status
  3. If the service is not running, start the services as below:
    # /etc/init.d/slipstream start
    Starting slipstream-server:           [  OK  ]
    
    # /etc/init.d/redis start
    Starting redis-server:                [  OK  ]
 
If the slipstream service does not start after a manual start, then check the log file /var/log/slipstream/slipstream-server.log
 
  1.  Permission related issue.
    Verify the ownership and permission of the below mentioned directories:
    /var/run/slipstream
    /var/run/redis
    /var/log/redis
    /var/log/slipstream


    Directory ownership and permission should be as follows:
    [root@space-005056ad125b log]# ll | grep slipstream
    drwxr-xr-x. 2 slipstream    slipstream      4096 May  7 22:12 slipstream
    
    [root@space-005056ad125b log]# ll | grep redis
    drwx--x---. 2 redis         root            4096 Jul 15 10:34 redis
    
    [root@space-005056ad125b run]# ll | grep slipstream
    drwxr-xr-x. 2 slipstream slipstream 4096 Jul 15 09:15 slipstream
    
    [root@space-005056ad125b run]# ll | grep redis
    drwxr-xr-x. 2 redis      root       4096 Aug  9 06:38 redis
    
    

  2. Disk space issue.
    Check the disk space usage using the df -kh command.
    ​[root@space-005056bd7d62 audit]# df -kh
    Filesystem                   Size  Used Avail Use% Mounted on
    /dev/mapper/jmpvgnocf-lvroot 42G  3.6G   36G  10%  /
    tmpfs                        16G    0    16G   0%  /dev/shm
    /dev/sda1                    93M   33M   56M  38%  /boot
    /dev/mapper/jmpvgnocf-lvtmp  48G   82M   46G   1%  /tmp
    /dev/mapper/jmpvgnocf-lvvar  524G   21G  477G  5%  /var
    /dev/mapper/jmpvgnocf-lvlog  39G  38G      0  100% /var/log


    In the example above, the /var/log partition is at 100% disk utilization.  This prevents the slipstream service from writing to the /var/log/slipstream/slipstream-server.log. 

    Identify the directories with the maximum usage; use the below command.
    [root@space-005056bd7d62 ~]# cd /var/log/
    [root@space-005056bd7d62 log]# du -hs * | grep G [This will provide us with the size of files and directories in /var/log/ which are in GBs.]
    [root@space-005056bd7d62 log]# du -hs * |grep G
    31G     audit
    2.1G    jboss


    If /var/log/audit directory is consuming the disk space in the /var/log partition, then follow the article KB33248 to free up disk space.

    Start the slipstream service using the below command.
    ​# /etc/init.d/slipstream start
    Starting slipstream-server:           [  OK  ]


Please Contact Support for further assistance.

Modification History:
24/01/2019 : Added one more cause for the issue and the solution.
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