Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[SRX] AppSecure license is missing on SRX

1

0

Article ID: KB33165 KB Last Updated: 11 Dec 2018Version: 2.0
Summary:

An administrator looks at the license and does not see the 'appid-sig' in the output of 'show system license' despite installing all licenses in any particular bundle that includes AppSecure.

 

Symptoms:

An administrator adds the licenses from the license bundle that is supposed to include AppSecure (appid-sig), but the administrator does not see it listed.

 
root@SRX4100> show system license

License usage:
                                 Licenses     Licenses    Licenses    Expiry
  Feature name                       used    installed      needed
  idp-sig                               1            1           0    2019-05-30 00:00:00 UTC
  remote-access-ipsec-vpn-client        0            2           0    permanent
 

The administrator wants to know how to get the AppSecure license on the SRX device.

 

Cause:

An AppSecure license is not needed on the following SRX devices:

  • SRX300

  • SRX320

  • SRX340

  • SRX345

  • SRX1500

  • SRX4100

  • SRX4200

  • SRX4600

For more information, refer to Predefined Application Signatures for Application Identification.

Example from this documentation

Starting from Junos OS release 15.1X49-D65 and Junos OS release 17.3R1, on SRX4100 and SRX4200 devices, AppSecure is part of the Junos Software Enhanced (JSE) license package (a default shipping software package). A separate license key is, therefore, not required on your device to download and install the AppID signature database updates, or to use other AppSecure features such as AppFW, AppQoS, and AppTrack.

 

Solution:

No license key enforcement is needed to use AppSecure on the above-mentioned SRX devices. However, customers should purchase the license that includes AppSecure for the right to use the feature.

 

Modification History:

2018-12-11: Solution section updated to include information about purchasing a license that includes AppSecure for the right to use the feature

 

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search