Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[EX/QFX] How to configure QinQ using ELS on Junos OS

0

0

Article ID: KB33838 KB Last Updated: 14 Feb 2020Version: 3.0
Summary:

This article describes how to configure QinQ by using Enhanced Layer 2 Software Support (ELS) on Junos OS.

Solution:

Example Topology:

Example Configuration:

CE-1

[master:0][edit]
root@CE-1# show vlans V10
vlan-id 10;
l3-interface irb.10;

[master:0][edit]
root@CE-1# show interfaces ge-0/0/1
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members V10;

[master:0][edit]
root@CE-1# show interfaces irb.10
family inet {
    address 10.10.10.1/24;

PE-1

[master:0][edit]
root@PE-1# show vlans V2000
interface ge-0/0/1.2000;
interface ae0.2000;

[master:0][edit]
root@PE-1# show interfaces ge-0/0/1
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
unit 2000 {
    vlan-id-list 10-100;
    input-vlan-map push;
    output-vlan-map pop;

[master:0][edit]
root@PE-1# show interfaces ae0
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
aggregated-ether-options {
    lacp {
        active;
        periodic fast;
    }
}
unit 2000 {
    vlan-id 2000;

PE-2

[master:0][edit]
root@PE-2# show vlans V2000
interface ge-0/0/1.2000;
interface ae0.2000;

[master:0][edit]
root@PE-2# show interfaces ge-0/0/1
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
unit 2000 {
    vlan-id-list 10-100;
    input-vlan-map push;
    output-vlan-map pop;

[master:0][edit]
root@PE-2# show interfaces ae0
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
aggregated-ether-options {
    lacp {
        active;
        periodic fast;
    }
}
unit 2000 {
    vlan-id 2000;

CE-2

[master:0][edit]
root@CE-2# show vlans V10
vlan-id 10;
l3-interface irb.10;

[master:0][edit]
root@CE-2# show interfaces ge-0/0/1
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members V10;

[master:0][edit]
root@CE-2# show interfaces irb.10
family inet {
    address 10.10.10.2/24;

Modification History:

2020-02-13: Replaced line diagram with an image since line diagram gets distorted when opened in browser.
2019-08-23: Corrected the PE interface in the topology diagram in the Solution section; no other changes made

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search