Knowledge Search


×
 

[EX/QFX] How to configure QinQ using ELS on Junos OS

  [KB33838] Show Article Properties


Summary:

This article describes how to configure QinQ by using Enhanced Layer 2 Software Support (ELS) on Junos OS.

Solution:

Example Topology:

 
+-------+             +--------+             +--------+             +------+
|       | ge-0/0/1    |        | ae0         |        | ge-0/0/1    |      |
| CE-1  +-------------+  PE-1  +-------------+  PE-2  +-------------+ CE-2 |
|       |    ge-0/0/1 |        |         ae0 |        |    ge-0/0/1 |      |
+-------+             +--------+             +--------+             +------+
           C-VLAN 10             S-VLAN 2000             C-VLAN 10
 

Example Configuration:

CE-1

[master:0][edit]
root@CE-1# show vlans V10
vlan-id 10;
l3-interface irb.10;

[master:0][edit]
root@CE-1# show interfaces ge-0/0/1
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members V10;

[master:0][edit]
root@CE-1# show interfaces irb.10
family inet {
    address 10.10.10.1/24;

PE-1

[master:0][edit]
root@PE-1# show vlans V2000
interface ge-0/0/1.2000;
interface ae0.2000;

[master:0][edit]
root@PE-1# show interfaces ge-0/0/1
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
unit 2000 {
    vlan-id-list 10-100;
    input-vlan-map push;
    output-vlan-map pop;

[master:0][edit]
root@PE-1# show interfaces ae0
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
aggregated-ether-options {
    lacp {
        active;
        periodic fast;
    }
}
unit 2000 {
    vlan-id 2000;

PE-2

[master:0][edit]
root@PE-2# show vlans V2000
interface ge-0/0/1.2000;
interface ae0.2000;

[master:0][edit]
root@PE-2# show interfaces ge-0/0/1
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
unit 2000 {
    vlan-id-list 10-100;
    input-vlan-map push;
    output-vlan-map pop;

[master:0][edit]
root@PE-2# show interfaces ae0
flexible-vlan-tagging;
encapsulation extended-vlan-bridge;
aggregated-ether-options {
    lacp {
        active;
        periodic fast;
    }
}
unit 2000 {
    vlan-id 2000;

CE-2

[master:0][edit]
root@CE-2# show vlans V10
vlan-id 10;
l3-interface irb.10;

[master:0][edit]
root@CE-2# show interfaces ge-0/0/1
unit 0 {
    family ethernet-switching {
        interface-mode trunk;
        vlan {
            members V10;

[master:0][edit]
root@CE-2# show interfaces irb.10
family inet {
    address 10.10.10.2/24;

Modification History:

2019-08-23: Corrected the PE interface in the topology diagram in the Solution section; no other changes made

Related Links: