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[STRM/JSA] Failed UBA application upgrade

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Article ID: KB34791 KB Last Updated: 23 Sep 2019Version: 1.0
Summary:

This article outlines the steps to install UBA V2.0.1 and preserve the original configuration settings, for administrators who encounter failed upgrades to UBA version 2.0.0.

Symptoms:

Failed UBA application upgrade

Cause:

The UBA 2.0.0 installer is missing a required package to complete the application installation. The application attempts to download this dependency from the Internet. If the Console does not have internet access, then the update will fail.

Solution:

Note: Administrators who want to preserve their LDAP configuration and UBA configuration data from their v1.4 installation must complete all the steps in this procedure. If administrators want to configure the application as a fresh installation and not preserve any application settings, then they can go directly to Step 3.

Step 1: Preserving your UBA application configuration

This step allows administrators with root access to SSH to the JSA Console and copy the settings files from the UBA application to a safe directory. This ensures that the UBA settings can be restored later on.

Procedure

  1. Using SSH, log in to the JSA Console as the root user.
  • To create a backup directory, type the following command:

mkdir uba_backup
  • To navigate to the newly created directory, type:

cd uba_backup
  • Type the following commands based on your JSA version:

    • If you are using JSA V2014.6 to V2014.8, type the following command:

      find /store/docker/vfs/dir/ -name uba.db
    • If you are using JSA V7.3.0, type the following command:

find /store/docker/volumes/ -name uba.db
  • PATH_TO_UBA_STORE_FOLDER is the value returned from the first command minus the file name part.

  • To back up the settings files, copy the UBA configuration files with the following commands:

cp [PATH_TO_UBA_STORE_FOLDER]/uba.db ./   
cp [PATH_TO_UBA_STORE_FOLDER] /config.json ./    

Step 2: Preserving your LDAP application configuration

Procedure

  1. Using SSH, log in to the JSA Console as the root user.
  • To create a backup directory, type the following command:

mkdir ldap_backup
  • To navigate to the newly created directory, type:

cd ldap_backup
  • Type the following commands based on your JSA version:

    • If you are using JSA V2014.6 to V2014.8, type the following command:

      find /store/docker/vfs/dir/ -name ldap-reference.db
    • If you are using JSA V7.3.0, type the following command:

find /store/docker/volumes/ -name ldap-reference.db
  • PATH_TO_UBA_STORE_FOLDER is the value returned from the first command minus the file name part.

  • To back up the settings files, copy the UBA configuration files with the following commands:

cp [PATH_TO_LDAP_STORE_FOLDER]/ldap-reference.db ./   
cp  ./[PATH_TO_LDAP_STORE_FOLDER]/config.json  ./ 
cp  -r [PATH_TO_LDAP_STORE_FOLDER] /certs  ./certs    

Step 3: Removing UBA from the JSA Console

This procedure outlines how to remove the UBA application from JSA. There are two possible methods of removing the application from JSA and both procedures are defined below:

  1. Procedure 1: Uninstalling from the User Interface
    1. Log in to the JSA Console as an administrator.

    2. Click the Admin tab.

    3. Click the Extensions Management icon.

    4. Select the User Behavior Analytics 2.0.0 app.

    5. Click the Uninstall button.

    6. To confirm the app removal, click Uninstall.

Results

A message is displayed to the administrator that any content added by the application, such as rules or custom properties, will still remain in the JSA Console. When the uninstallation process completes, a summary is displayed.

  1. Procedure 2: Uninstalling UBA V2.0.0 Using the JSA API
    1. Log in to the JSA Console as an administrator and from the navigation bar, select Help > Interactive API for Developer or from your browser address bar type: https://ConsoleIPAddress/api_doc. Both methods will navigate the administrators to the JSA API.

    2. Authenticate to the JSA API.

    3. Select the top API version on the left panel, such as v8.0 or v7.0, depending on your JSA version.

    4. Expand the /gui_app_framework endpoint.

    5. Select /applications.

    6. On the GET - /gui_app_frameworks/applications screen, click the Try It Out! button.

    7. In the Response Body, locate the application_id or app_id number for the UBA application.

      Note: To verify, ensure that the “name” field of the entry is “uba_core.application_name" and record the numeric value.

    8. Select the /  endpoint and then click the DELETE tab.

    9. In the application_id field, type the number for the application_id that you recorded in step 7 into the Value field.

    10. Click the Try It Out! button.

Results

A 204 response should be returned with the message: The application has been successfully unregistered.

Note: If you get any of the following response codes, you might need to contact Support: 409 or 500. If you receive a 404 response code, verify that you typed the correct application_id number because the API is informing the administrator that the specific application_id does not exist, so there was nothing to delete.

 

Step 4: Installing UBA V2.0.1

This procedure walks the administrator through the process of installing UBA V2.0.1, and then restoring the configuration files.

Procedure

  1. Download the UBA v2.0.1 application from App Exchange.
  2. Log in to the JSA Console as an administrator.

  3. Click the Admin tab, and then click the Extensions Management icon.

  4. In the Extension Management window, click Add and select the UBA V2.0.1 zip archive to upload.

  5. Select the "Install immediately" check box.

  6. On the Admin tab, click Advanced > Deploy Full Configuration.

Results

The UBA V2.0.1 app is installed. If you did not save any backup settings from your V1.4 or V2.0.0 UBA installation, then you should review the setup procedures for the UBA app from the official documentation.

If you are restoring configuration files, see Step 5.

 

Step 5: Restoring Configuration Files to UBA V2.0.1 App

This procedure walks the administrator through the process of installing UBA V2.0.1, and then restoring the configuration files.

Note: Perform these steps only to restore your original UBA and LDAP settings:

Procedure

  1. Using SSH, log in to the JSA Console as the root user.
  2. Navigate to the following directory:

uba_backup
  • If you are using JSA V2014.6 to V2014.8, run the following command:

find /store/docker/vfs/dir/ -name uba.db
  • If you are using JSA V7.3.0, run the following commands:

find /store/docker/volumes/ -name uba.db
  1. PATH_TO_UBA_STORE_FOLDER is the value returned from the first command minus the file name part.

  2. To restore the settings files, copy the UBA configuration files with the following commands:

cp uba.db [PATH_TO_UBA_STORE_FOLDER]
cp config.json [PATH_TO_UBA_STORE_FOLDER]
  1. Navigate to the following folder containing your LDAP configuration backup:

ldap_backup
  • If you are using JSA V2014.6 to V2014.8, run the following command:

find /store/docker/vfs/dir/ -name ldap-reference.db
  • If you are using JSA V7.3.0, run the following command:

find /store/docker/volumes/ -name ldap-reference.db
  1. PATH_TO_LDAP_STORE_FOLDER is the value returned from the first command minus the file name part.

  2. To restore the LDAP configuration files, type the following commands:

cp  ./ldap-reference.db [PATH_TO_LDAP_STORE_FOLDER]
cp  ./config.json [PATH_TO_LDAP_STORE_FOLDER]
cp  -r  ./certs/* [PATH_TO_LDAP_STORE_FOLDER]/certs/

Results

From the JSA user interface, launch the UBA application and verify that the configuration is complete and that the data is restored.

 

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