Support Support Downloads Knowledge Base Service Request Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[Sky ATP] Enrollment Failure: error: XPath evaluation returned no result

0

0

Article ID: KB34873 KB Last Updated: 14 Aug 2019Version: 1.0
Summary:

While attempting to enroll SRX300 or SRX320 into Sky ATP Cloud, several errors appear and enrollment fails. To avoid this issue, ensure SRX devices have Junos 18.3R1 or higher.

Symptoms:
srx> op url <enrollment script>
Platform is supported by Sky ATP: SRX320.
Version 15.1X49-<Maintenance Release> is valid for bootstrapping.
Branch device detected.
Check security forwarding process enhanced services mode...
Enhanced services mode is turned on.
Going to enroll single device for SRX320: <serial number> with hostname <srx hostname>.
Application Signature DB version on this device is: <appid version>. Using latest version of Application Signature DB is recommended.
Remove related security-intelligence service configurations...
Remove related advanced-anti-malware service configurations...
Remove related SSL service configurations...
Remove related PKI configurations...
Clear local certificate aamw-srx-cert...
Clear key pair: aamw-srx-cert...
Clear CA profile aamw-cloud-ca...
Clear CA profile aamw-secintel-ca...
Configure CA...
Request aamw-secintel-ca CA...
Wait aamw-secintel-ca CA download status...
Load aamw-secintel-ca CA...
Request aamw-cloud-ca CA...
Wait aamw-cloud-ca CA download status...
Load aamw-cloud-ca CA...
Retrieve CA profile aamw-ca...
CA certificate ready: aamw-ca...
CA certificate ready: aamw-cloud-ca...
CA certificate ready: aamw-secintel-ca...
Generate key pair: aamw-srx-cert...
Communicate with cloud...
License type for this device: premium.
License of your device will expire in 433 days.
Enroll local certificate aamw-srx-cert with CA server...
Configure SSL service...
xnm:rpc results:5:(4) Premature end of data in tag load-configuration-results line 4
xnm:rpc results:5:(3) Premature end of data in tag rpc-reply line 3
xnm:rpc results:5:(2) Premature end of data in tag junoscript line 2
error: commit script: xml-mode: could not read content
error: invalid reply to rpc
error: could not get reply
error: xmlXPathCompiledEval: No result on the stack.
error: runtime error: file /var/tmp/tmp_opDaoDT4/...transferring.file.........<enrollment script data> line 1520 element value-of
error: XPath evaluation returned no result.
Cause:

SRX300 and SRX320 are installed with Junos 15.1X49.

Solution:

In order to enroll SRX300 and SRX320 devices into Sky ATP Cloud, these devices must have Junos 18.3R1 or higher per the Supported Platforms Guide

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Security Alerts and Vulnerabilities

Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search