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[BTI] BTI7800 becomes unreachable in PSM due to network latency increase

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Article ID: KB34892 KB Last Updated: 17 Sep 2019Version: 1.0
Summary:

Sometimes, the BTI7800 device nodes may become unreachable in the PSM client even though the network between the PSM server and the Network Element (NE) is normal and the NE is reachable. The error Netconf IO Error: [Error getting netconf data [Failed to get operation result within specified timeout: 5000]] may be reported on the PSM task bar.

In this article, you understand why the timeout error is reported and how it can be resolved.

Symptoms:

The PSM server reports the BTI7800 node unreachable alarm, even though the network is otherwise normal and the Network Element (NE) is reachable via SSH or other methods.

When customers try to rediscover the NE from the PSM server, the following error message may appear on the task bar as follows:

Netconf IO Error: [Error getting netconf data [Failed to get operation result within specified timeout: 5000]]

Customers can confirm whether the issue is related to Netconf timeout by checking for the error message on the PSM task bar.

Cause:

PSM periodically polls the Network Elements to update its database with the most current NE configuration or statistics. Because networks can become busy during peak hours due to heavy use, the default Netconf timeout value may not be sufficient to receive complete data from the Network Elements.

Solution:

The default Netconf connection timeout is set to 5000 milliseconds and is defined in the common.properties file under /usr/local/ems9001/conf.

[root@PSM conf]# pwd
/usr/local/ems9001/conf
[root@PSM conf]# cat  common.properties | grep netconf.defaultConnectionTimeout
netconf.defaultConnectionTimeout=5000

To resolve the timeout issue, you need to increase the value for netconf.defaultConnectionTimeout. A value of 50,000 is recommended based on experience.

To change the default Netconf connection timeout value, perform the following steps:

Note: Do not modify the /usr/local/ems9001/conf/common.properties file. Instead, copy sections or individual lines into the override file as described below, and make the changes there.

  1. Stop the server by entering the following command:
psm-stop

The stop command is successful when all the "Ems-" processes change to the "not monitored" state. Press Ctrl+C to exit the Linux watch command window.

  1. Edit the /var/local/ems9001/conf/override-common.properties file. Add the line as shown below with the new value of 50000. 
netconf.defaultConnectionTimeout=50000

Save and close the file.

  1. Start the PSM server for the changes to take effect.
psm-start

The start command is successful when all the "Ems-" processes change to the "running" state.

Press Ctrl+C to exit the Linux watch command window.

When the PSM server is started successfully, reconnect with the PSM client and attempt to rediscover the BTI7800 node. The alarm will have cleared.

Note: The issue may also occur when the BTI7800 device is upgraded from 1.x to 4.x. Since additional features have been added in BTI7800 R4.x, additional time may be required for Netconf to retrieve all the required information due to which the default connection timeout value may be exceeded.

Changing the default timeout value can also clear the unreachable alarm.

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