Knowledge Search


×
 

[CSO] Unable to add Cloud hub Error: No eligible OAM hubs present in the this Tenant

  [KB34946] Show Article Properties


Summary:

This article discusses the issue when a user is unable to add cloud hub in 5.0 CSO.

Symptoms:

Steps to trigger:

  1. Login to CSO - Create cloud hub device.
  2. Site Capability: DATA_ONLY
  3. POP is JNPR_CLOUD
  4. Authentication is PSK
  5. Select WAN interfaces per design.

Result:

The job is created, but with OAM-related failure:

PMService: tssmLevel: ERROR
Message: oam_hub_selector: least_ipsec_tunnels_on_hubs : Error occurred while selecting hub for topo site: oam_hub_selector: no eligible OAM hubs present in the tenant XXXXXXX
Aug 20, 2019, 9:24:06 PMService: tssmLevel: ERROR
Message: oam_hub_selector::Error occurred while adding oam overlay tunnel and hub info: None for the device: cloud-demo-hub2 error:oam_hub_selector: no eligible OAM hubs present in the tenant XXXXXX

Solution:

If the OPCO is created in CSO 5.0, then we need to import OAM hub(s) under OPCO scope using site-management page before onboarding data hubs. For tenant/OPCO created from CSO 5.0.1 release, CSO automatically imports OAM hubs.

Import all OAM hub(s) of type – PSK (hub name indicates this) in OPCO scope and try on boarding the data hub again. Since OPCO does not have usable OAM hubs in this case, onboarding fails with error – 'Failed launching configure-sites task:oam_hub_selector: no eligible OAM hubs present in the tenant <tenant name>' which is expected.

Related Links: