Support Support Downloads Knowledge Base Case Manager My Juniper Community

Knowledge Base

Search our Knowledge Base sites to find answers to your questions.

Ask All Knowledge Base Sites All Knowledge Base Sites JunosE Defect (KA)Knowledge BaseSecurity AdvisoriesTechnical BulletinsTechnotes Sign in to display secure content and recently viewed articles

[SRX] SkyATP Enroll/Disenroll attempt results in 'File-fetch fail'

0

0

Article ID: KB35140 KB Last Updated: 10 Oct 2019Version: 1.0
Summary:

When attempting to run either an enrollment script or a disenrollment script for Sky ATP, an immediate error returns 'error: File-fetch failed'.

Symptoms:
root@SRX> op url https://amer.sky.junipersecurity.net/v2/skyatp/ui_api/bootstrap/disenroll/........a4box/.......197phafj.slax
error: File-fetch failed
Cause:

This error is triggered when another new enroll/disenroll script has been generated in the Sky ATP portal after the one which is attempting to be executed.

Each time either an enroll or disenroll script is generated in a SkyATP customer realm, it invalidates all previously generated scripts of either type. 

For example, if you generate a "disenroll" script, then immediately generate an "enroll" script, the "disenroll" script will become invalid.  If you try to run it on an SRX device the "error: File-fetch failed" error message will be returned.

Solution:

Generate and execute enroll/disenroll scripts as you create them. Do not attempt to create multiple scripts at a time. 

Comment on this article > Affected Products Browse the Knowledge Base for more articles related to these product categories. Select a category to begin.

Getting Up and Running with Junos

Getting Up and Running with Junos Security Alerts and Vulnerabilities Product Alerts and Software Release Notices Problem Report (PR) Search Tool EOL Notices and Bulletins JTAC User Guide Customer Care User Guide Pathfinder SRX High Availability Configurator SRX VPN Configurator Training Courses and Videos End User Licence Agreement Global Search